Page MenuHome

Material Libary VX Issues
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card

Windows 7 64 Bit, Nvidia 760gtx

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

Addon is new introduced in Blender 2.79 RC 1

Short description of error

Material Library VX has some issues. The functionality is there, but it throws errors in the console at some operations:

  • Two path not found message in the console right at startup when addon is activated.
  • Shows a Blender Quit message at switching the libraries, including a path not found warning. Obviously Blender is still running though ...
  • Right click at a material shows a search for unknown menu type WM_MT_button_context warning.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Open 2.79 RC1, activate the Materials Library VX addon, save user preferences. Close Blender, open Blender, have a look in the console. You will find two path not found warnings.

Change the material library to cycles or BI. You will get a few path not found warnings, plus a irritating Blender Quit message in the console.

Right click at one of the materials. You will get a search for unknown menu type WM_MT_button_context warning.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

We do not accept bug reports about third-party add-ons not distributed with Blender, those shall be reported to the add-on's author(s).

Um, this addon is included in Blender 2.79 RC1 :)

Bastien Montagne (mont29) reopened this task as Open.
Bastien Montagne (mont29) triaged this task as Normal priority.

Hmmpf, my bad… didn’t knew it was named that way. :|

hi, we do know about these issues and have been trying to solve the errors.
we can take another look and possibly add a warning to the addon.

The only real issue is with the path not found message that is not really clear and probably needed rephrasing or hiding it behind a debug flag.

The other two come from Blender itself.
The Blender Quit is related to the way Blend files are loaded in the background for reading the materials as they are stored inside them.
The WM_MT_button_context warning message was introduced / consequence of the commit that allowed Custom Python entries in the right click menus (see D2612)

All these are not really errors but i do understand from the user perspective they seems so (similar to the good old Audaspace 44100 48000 not found one)

Just a heads up, I just fixed this point: "Right click at one of the materials. You will get a search for an unknown menu type WM_MT_button_context warning."

Vuk Gardašević (lijenstina) closed this task as Resolved.EditedSep 6 2017, 8:14 PM

The issue with the empty path should be resolved in 841fcc68d77f in master. We'll see if it is going to be added to the 2.79 release.
The second one is like I said related to loading a blend file in the background and I don't think it is inside the add-on itself.

Since those issues that can be solved are addressed we can close this task.