Snap Cursor to Selected (Edit Mode) : lack of control and hidden functionalities
Closed, ArchivedPublic

Description

Blender Version
Broken: all versions up to 2.79 RC2

Short description of error

In Edit Mode, when the pivot point is set to Median Point, the Snap Cursor to Selected operator uses the medians of the vertices. When the pivot point is set to Bounding Box Center, the cursor snaps to the bounding box. However, the confusing thing is that we would then expect this operator to be influenced by the Pivot Point setting (e.g. when set to Active Element it would snap to the active element), but that's not the case. Only Median Point has an influence on it. All the other settings result in snapping to the bounding box center. Of course there's the Snap Cursor to Active operator but then why not have a Cursor to Median operator ?

‪‪ ‏‏‏
STEPS TO REPRODUCE

Open this file :

  1. set Pivot Point to Median Point
  2. do Shift+S > Cursor to Selected : it uses the median
  3. set Pivot Point to Bounding Box Center
  4. do Shift+S > Cursor to Selected : it uses the bounding box
  5. set Pivot to Active Element
  6. do Shift+S > Cursor to Selected : it uses the bounding box
  7. be confused

And there's more.
When the Pivot point is set to Bounding Box, the pivot goes on the object-space bounding box, but the 3D cursor snaps to the world-space bounding box, not letting you any choice.

  1. in Object Mode, Rotate the object on X by -30 and on Z by -30
  2. in Edit Mode, while Pivot Point is set to Bounding Box, snap the Cursor to Selected : it's not on the same spot as the Pivot because the Pivot is in object-space.


PROPOSAL

  • In the Pivot Point dropdown, have a choice between world-space and object-space Bounding Box
  • then when snapping Cursor to Selected, add Tool Shelf dropdown options :
    • Median
    • Bounds (World)
    • Bounds (Object)

      and make Median be the default when the Pivot Point is set to Median, World Bounds be the default when the Pivot is set to World Bounds, etc... so we have full control, no hidden functionality and no confusion.

Details

Type
Bug
Caetano (Caetano) updated the task description. (Show Details)
Caetano (Caetano) updated the task description. (Show Details)
Caetano (Caetano) updated the task description. (Show Details)
Caetano (Caetano) updated the task description. (Show Details)
This comment was removed by Caetano (Caetano).
This comment was removed by Caetano (Caetano).
Caetano (Caetano) updated the task description. (Show Details)
Caetano (Caetano) updated the task description. (Show Details)
Caetano (Caetano) renamed this task from Inconsistency in Snap Cursor operators to Inconsistency in Snap Cursor operators (Edit Mode).Aug 12 2017, 1:16 AM
Caetano (Caetano) updated the task description. (Show Details)
Caetano (Caetano) updated the task description. (Show Details)
Caetano (Caetano) updated the task description. (Show Details)
Caetano (Caetano) updated the task description. (Show Details)

I can reproduce this. It seems more like a design issue than a(n implementation) bug.

I agree it is a design discussion. But I don't see a real issue.
A user that doesn't know this behaviour will expect Snap Cursor to Selected to be restricted to one option.
But it is a plus to have choïce between Median of selected elements or Bounding Box Center of selection.
Option could be explicit. A checkbox option added to choose for this case would be sufficient to disconnect the operator from pivot point.

But it makes no sense to create a Cursor to Pivot Point operator. A confusion would be added by existence of pivot points that are making no sense for that action.
What would be the expected behaviour of a Snap Cursor to Cursor or a Snap Cursor to Individual Origins ?

And it is probably the reason why these irrelevant pivot points correspond to a default : Bounding Box Center.
They are making no sense for a snap cursor to selected operation and a solution is already provided for snap to active.

The object space bounding box for selection in edit mode can be seen as a user request.
It is probably something to add to brita's User Coordinate Spaces project.
https://developer.blender.org/T43964

Caetano (Caetano) added a comment.EditedSep 2 2017, 3:54 PM

You made some good points. I update my proposal :

  • In the Pivot Point dropdown, we could still have the additional choice between World and Object-Space Bounding Box
  • then when snapping "Cursor to Selected", we could have Tool Shelf dropdown options such as : Median ; Bounds (World) and Bounds (Object) and make Median be the default when the Pivot Point is set to Median, World Bounds be the default when the Pivot is set to world bounds, etc... so we have full control, no hidden functionality, no additional item when hitting Shift+S and no confusion.

Does this work for you ?

Yes. As is, it works. But, imho, it is a design task to archived as a todo.
It is weird to make such kind of changes at the end of a series.
There are probably other things that could benefit of an object space rather than global one.
Maybe your proposal would not stay relevant when this part of Blender would be reviewed by 2.8 project.

I haven't heard of a planned change in the behavior of the 3D cursor for 2.8 but I'm not involved enough to know. You probably know better, so, do as you wish

Caetano (Caetano) renamed this task from Inconsistency in Snap Cursor operators (Edit Mode) to Snap Cursor to Selected (Edit Mode) : lack of control and hidden functionalities.Sep 3 2017, 12:28 PM
Caetano (Caetano) updated the task description. (Show Details)
Sergey Sharybin (sergey) closed this task as Archived.Sep 13 2017, 1:48 PM
Sergey Sharybin (sergey) claimed this task.

Thanks for the report, but it's simply how Blender works. Improvements are possible, but bug tracker is not the place to discuss such changes. Use bf-funboard mailing list for that and get someone to implement good proposal or submit a patch here :)