Page MenuHome

Blender FBX Export
Closed, ArchivedPublic

Description

System Information
Windows 10 Home, AMD Radeon R9 200 / HD 7900 Series

Blender Version
2.78

Short description of error
Ok so when i an export a mesh with a rig with all correct settings than import into unreal, it detects the armature as a bone, ive read this has caused other people issues. Here is your fix.
https://krisredbeard.wordpress.com/tutorials/tutorial-prevent-blender-fbx-exporter-adding-extra-root-bone/
After doing as the above link sets out. It no longer detects the armature as a bone and imports the correct amount of bones.

Exact steps for others to reproduce the error

  1. Make a Model
  2. Rig
  3. export
  4. import into unreal
  5. open skeletal mesh and look at skeleton
  6. Witness the extra bone.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Normal priority.

This is more like a hack than a fix… I don’t mind adding it to the addon - but this will be yet another option, and it will most certainly break some animations indeed… Correct fix would rather be that UE does not always consider empty parents of bones as a bone!

Ok thanks, ill post a thing on unreal engine support relating to what you specified.

Brendon Murphy (meta-androcto) closed this task as Archived.

closing as archived, no activity since 2017