Page MenuHome

Dupliverts disappear when on non renderable layer
Closed, ArchivedPublic

Description

System Information
Win 8.1x64 3x gtx580

Blender Version
2.79t2

Short description of error
When viewport is unlocked from global layers, dupliverts are displayed only when they are in a layer that is visible for rendering. Don't know if it is a bug or has some reasoning behind, but it is not mentioned in the manual and seems not to be logically tied to anything either.

Exact steps for others to reproduce the error

  • Press "M" and then "2", to move selected objects to layer 2.
  • Dupliverts disappear.

Details

Type
Bug

Event Timeline

No, it is logical.
Object is moved to a scene layer ignored by renderlayer. So, duplis would not be rendered.
Duplis were originally thought as instances for rendering. You don't give an existence to instances that would not be rendered.

I understand that as duplis used to model something that would be converted as real meshes it can be weird.
But it is a design discussion. It is not a regression or a bug. It works the same in 2.78.
And long time ago, it was more weird because; you could not have original dupli object on a different layer than its parent.

Sure, manual could be completed. But anyways, this discussion will not persist in 2.8 with new renderlayer system where you saw is what is get for specified engine (EEVEE, Cycles, Clay).

you could not have original dupli object on a different layer than its parent.

If I understand you correctly, dupliverts are still not rendering, when parent and child exist on different layers and only one layer is selected.

@Ronan Zeegers (ronan) ducluzeau
Yes, I was using it for modelling and thank you for an insight and explanation of the reasons, but that is not the same as being logical :)

  1. "Only Render" display is disabled, thus it is logical to expect the view not to be influenced by what will be rendered.
  2. Viewport layers are detached from render layers, thus it should be only affected by layers that are set locally.

2.b. Additionally, if you press F12 you render local, not global layers (which I see as pure inconvenience, but that's definitely a design choice, thus who am I to object), so dupliverts should be visible even according to what you explained.

If I understand you correctly, dupliverts are still not rendering, when parent and child exist on different layers and only one layer is selected.

No, I just mean that it used to work as is long time ago in 2.4x or 2.3x series.

"Only Render" display is disabled, thus it is logical to expect the view not to be influenced by what will be rendered.
Viewport layers are detached from render layers, thus it should be only affected by layers that are set locally.

2.b. Additionally, if you press F12 you render local, not global layers (which I see as pure inconvenience, but that's definitely a design choice, thus who am I to object), so dupliverts should be visible even according to what you explained.

I mean the logic used here is that dupli are created only if they can be rendered.
It is not really connected to viewports layers. It is related to scene layers.
In your example, everything is moved on layer 2. So cube or plane will not be rendered because only scene layer 1 is enabled.
If you enable scene layer 2 under renderlayer panel, duplis are reappearing although viewport layers are no more synced with scene layers.

If you press F12, you always render according to renderlayer set-up (boolean intersection of scene layers and renderlayer layers).
So, global layers are always involved.

There are lots of dependencies between render and viewport in both directions. Many times, a correct render implies to set viewport setting equal to render one.
I am not saying that blender should work like that. I am just saying that it was build like that. 2.8 evolution should clarify everything between render and viewport.
You want to model -> build a renderlayer for Clay engine with its own collections and overlays.
You want to render -> build a renderlayer for Cycles engine with its own collections and overlays.

"If you press F12, you always render according to renderlayer set-up."
Nope - try it.

Bastien Montagne (mont29) closed this task as Archived.Aug 26 2017, 3:18 PM
Bastien Montagne (mont29) claimed this task.

This definitively does not sounds like a bug, more like design discussion, which shall happen on bf-committers ML, not on the tracker. Thanks for the report anyway.