Page MenuHome

MMB doesn't work with IBM/Lenovo Trackpoint/Trackpad
Closed, ArchivedPublic

Description

System Information
Fedora 26 on Thinkpad T520

Blender Version
Broken: 2.78c as shipping with Fedora 26 for x86_64; another user on #blender reported having the same issue on Fedora 25.
Worked: Some older version, exact version not known.

Short description of error

Exact steps for others to reproduce the error
Start blender with the default scene and default settings. Press middle mouse button of the three mouse buttons below the laptop's space bar and move the TrackPoint in any direction. Orbiting won't work, that is moving left or right will not have any effect while moving up and down will zoom in and out.

The T520 also has a trackpad with two further buttons below it. While the middle mouse button emulations of both the Gnome desktop and blender are disabled there still seems to be another type of middle mouse button emulation enabled, that is pressing both thee buttons (the timing is a bit hard to hit) and using either the TrackPoint or the touchpad will orbit as expected.

An external USB mouse with scroll wheel will also work as expected.

Neither the Gnome's nor Blender's middle mouse button emulation seem to make a difference, in fact I can't seem to get it to work with the Trackpoint's three buttons.

I've tried alternative Fedora 26 desktops, that is Gnome, Gnome Classic, Gnome on Xorg, Openbox, Plasma and Xfce, all with the same result.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Normal priority.Aug 26 2017, 3:41 PM

Am sorry, but there’s not much we can do here, this sounds like a system/hardware configuration issue, unless that trackpoint generates odd kind of system (X11) events… But in any case, we need a dev with that kind of hardware to investigate, not sure any of us has some…

The issue reported can't be reproduced so far, and has been moved to the BF Blender:_unconfirmed project.
If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.

We appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.
If there is anything you can provide to help others to reproduce the problem, be sure to include it.

Bastien Montagne (mont29) renamed this task from Orbiting doesn't work with Trackpad to Orbiting doesn't work with IBM/Lenovo Trackpoint/Trackpad - Need a dev with that kind of hardware to investigate!.Aug 26 2017, 3:41 PM
Bastien Montagne (mont29) renamed this task from Orbiting doesn't work with IBM/Lenovo Trackpoint/Trackpad - Need a dev with that kind of hardware to investigate! to MMB doesn't work with IBM/Lenovo Trackpoint/Trackpad - Need a dev with that kind of hardware to investigate!.

I had this problem too on my T520 (and X220).
Turns out to be a scroll type setting.
Standard: Will use the MMB as a override to emulate scrolling (with the scroll wheel) with either a locked x or y axis.
i.e. scrolling left/right with the scroll wheel doesn't work, even with a mouse.
Smooth: Will use MMB as a MMB holding it down whilst moving the mouse. (what Blender expects)


But since Lenovo doesn't have Linux drivers I think your out of luck.
Though one thing you could try: installing Windows and the UltraNav driver change the scroll type, test it and then in stall Linux, as I believe they're hardware settings and are saved in the BIOS.

@Bastien Montagne (mont29) Didn't want to close with the title being what it is. :)

@Christopher Anderssarian (Christopher_Anderssarian) no idea why you assigned that to me, I do not have any hardware of that kind, so absolutely no way to investigate and fix the issue…

@Bastien Montagne (mont29) I gave an answer to the problem here T52476#501499 and I needed you to remove the text in the title: "Need a dev with that kind of hardware to investigate!"
As the triager I thought I would ask you to change the title back, before closing the task.

Bastien Montagne (mont29) renamed this task from MMB doesn't work with IBM/Lenovo Trackpoint/Trackpad - Need a dev with that kind of hardware to investigate! to MMB doesn't work with IBM/Lenovo Trackpoint/Trackpad.Nov 26 2018, 10:58 AM
Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

Ah, so it can be closed then, wasn’t sure… title renaming was not really mandatory, but ok, done :)