Linux - Audio Mixdown - flac audio isnt created correctly
Closed, ResolvedPublic

Description

System Information
Linux x64
Blender Version
Broken: b94a433ca34

Short description of error
flac audio generation isnt generated cleanly

Exact steps for others to reproduce the error

  1. Open attached blend file
  2. export audio flac
  3. add this flac file back into blender
  4. notice how it is 0 frames long
  5. repeat on windows
  6. flac file is correct length and read correctly.

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as Confirmed priority.

The export seems to be working OK, it’s the import back into Blender that is broken somehow. Note that reading generated .flac in player (like default gnome one) does work.

@Joerg Mueller (nexyon) this is probably one for you?

Loading windows created flacs back in on Linux blender are correct length

There's also another bug which may or may not be related that FLAC creation stops early on long sequences (20-30k frames). Will report it as a separate bug if it's not related

I can't reproduce this bug. Can you tell me which distribution and version you are on and how you get blender? Official builds, distribution builds or self built? I guess it's a faulty ffmpeg version that causes this, probably not much we can do.

Ubuntu 17,04
Official build bot - rBb94a433ca34
Self built - rBe4762980840 (this just reports an error loading the flac, not same error as above)

Ok I can reproduce the bug with a buildbot build, but it's not a debug build, so it's hard to track down the error. @Sergey Sharybin (sergey) can you help? Which linux is the buildbot running and which ffmpeg/libsndfile version? Is it a self built one? Can I get it somehow?

I just saw that the buildbots build without libsndfile, so the cause could/should be ffmpeg. Do you build with libsndfile @Carlo Andreacchio (candreacchio) ?

@Joerg Mueller (nexyon), buildbot/release environment was silently ignoring sndfile. Making tweaks now to enable it back (as per blender_full.cmake).

Buildbot is based on Debian Jessie, with sndfile installed from repository, ffmpeg is 3.2.1. if enabling sndfile doesn't solve the issue i can share all self-compiled libraries from /opt/lib if you'd like.

Thanks @Sergey Sharybin (sergey) ! With libsndfile disabled I can reproduce the error with ffmpeg.

Then I tried blender2.8 where everything works, since the new audaspace uses newer ffmpeg API. Now we have a few options:

  1. We do nothing since it will be fixed with 2.8 and 2.79 official should be working since it uses libsndfile.
  2. I can backport from 2.8 and we drop the old ffmpeg code, releasing the new one with 2.79 (would drop support for older ffmpeg versions, don't know how old though... so far nobody reported problems with building the 2.8 ffmpeg audaspace code).
  3. I shoot myself, because ffmpeg...

What's your suggestion @Sergey Sharybin (sergey) ?

@Joerg Mueller (nexyon), let me finish getting buildbot up and running again (stupid nvcc crashes on sm20/sm21 kernels, keeps time to get past that to get fresh builds). If the new buildbot will work, i think we can consider the issue as resolved.

We definitely don't want you to shoot yourself!

Hey @Sergey Sharybin (sergey) I just checked the build bots, while the 64 bit linux builds still fail, I checked both 32 and 64 bit and they now both have WITH_CODEC_SNDFILE as ON. So we can consider this resolved?

@Joerg Mueller (nexyon), think so. Will try to get buildsbots running later today.

Sergey Sharybin (sergey) closed this task as Resolved.Sep 14 2017, 4:58 PM

@Joerg Mueller (nexyon), all buildbots should be up, and both 2.79 and latest buildbots are supposed to have sndfile enabled. So think the issue can be considered fully resolved now.