Render discrepancies between packed and unpacked normal maps
Closed, ArchivedPublic

Description

System Information
Windows 10, Nvidia GT620

Blender Version
Broken: 2.75, 2.78c, 2.79rc2
Worked: (optional)

Short description of error
Normal maps render differently when they are packed in the scene from when they are unpacked

Exact steps for others to reproduce the error

1.Unpack files
2.render
3.pack files
4.render on a different slot
5.compare differences

Details

Type
Bug
Sergey Sharybin (sergey) closed this task as "Archived".Mon, Sep 11, 9:59 AM
Sergey Sharybin (sergey) claimed this task.

The issue is caused by Cycles attempting to do color management on its side. This color management only works for non-packed images, for packed ones Cycles is fully relying on Blender side color management. This means, currently to make things render correct you need to both select No-color data in the Image Texture node AND select input colorspace of image itself as Non-color.

This is confusing, but not currently considered a bug: unifying color space management is a known TODO to happen in context of Cycles+Blender.

Thanks for the report, but closing it now.

Understood. Thank you so much, Sergei!