Page MenuHome

Frequent crashes when toggling edit mode with subsurf
Closed, ResolvedPublic

Description

System Information
Ubuntu 16.04 LTS/ GTX 1070 8GB


Blender Version
2.79RC2 7b397cdfc81,
Worked: (optional)

Short description of error
Quite often when modelling an object with subsurf active, Blender will crash when toggling edit/ object mode. As I am not sure of a reliable way to reproduce on another system, I have attached a few recent crash reports generated by Blender running under RC2.

Exact steps for others to reproduce the error
Not sure how to most reliably reproduce, on my system crashes are fairly random, but seem to come from subsurf modelling and trigger by toggling edit/ object mode.

One such file that has crashed is attached, hopefully it can be of some help.


Details

Type
Bug

Event Timeline

I can confirm this.
I use blender as much as the pipeline (max+vray) permits in production on a daily basis.
This and the SelectShortestPath bug (that I have just reported) are the biggest stoppers for me to start using 2.79

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Sep 11 2017, 9:12 AM

Pretty sure this has been fixed already, cannot replicate in current master nor in current 2.79 branch, to which a serious modifiers-related crasher was backported after 2.79 RC2 was published.

Can you please try the latest build from our buildbot?

@Bastien Montagne (mont29)

Tested today with the latest buildbot, and haven't had a single crash.

Bastien Montagne (mont29) closed this task as Resolved.Sep 12 2017, 7:34 AM
Bastien Montagne (mont29) claimed this task.

Thanks, fix shall also be in 2.79 released today, so we can consider this as fixed I think. :)

Hi, @Bastien Montagne (mont29) , unfortunately, this issue seems to persist (although not as often as previously) in release as well as in dc86b7a (own build from master).

I have attached both the currently affected .blend file and crash.txt from both builds. I will continue testing further, but thought perhaps should mention that this is still occurring.


Even holding the tab button for a few seconds, I could not replicate the bug.

But, if it helps the developers, I made a patch that proposes to fix definitively all the problems involving Subsurf + Shrinkwrap: