AMD GPU does not work after 2.79 update (Worked on 2.78c)
Closed, InvalidPublic

Description

System Information
OS: Windows 10
GPU: AMD R7 265 (Driver version 17.9.1)

Blender Version
Broken: 2.79 Hash:5bd8ac
Worked: 2.78c

Description of Error
As of the latest update 2.79, under USER PREFERENCE>SYSTEM>CYCLES COMPUTE DEVICE will not recognize my AMD R7 200 series GPU using architecture Pitcaim. However, As of version 2.78c, the GPU was recognized right away under these same settings. Not sure if this is a bug or if the compatibility for this GPU is discontinued which would make me sad and somewhat more broke :(

Ultimately, can not use the GPU rendering on the new update (2.79). I uninstalled the 2.79 update and rolled back to 2.78c to confirm the difference. With no other external updating of drivers or software, the GPU still works with 2.78c. After testing again and again on 2.78c, I uninstalled and installed 2.79 and still confirmed no GPU rendering for 2.79. AMD drivers as of now are up to date.

Other than that, love the denoising, and I think the CPU rendering on my end has improved greatly! And I got an 8 year old AMD FX processor.

Cheers!

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug
Sergey Sharybin (sergey) closed this task as Archived.Sep 13 2017, 3:57 PM
Sergey Sharybin (sergey) claimed this task.

Please check the release notes: https://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.79/Cycles#OpenCL

There are serious issues in OpenCL compiler for older cards which we can not workaround from our side, without causing ALL GPUs to suffer performance drop or disabling some features. If you're fine with performance and feature set of previous release, you can always use that for GPU render, but within current realities we can not push those cards any further.

So thanks for the report, but closing it now.

LazyDodo (LazyDodo) changed the task status from Archived to Invalid.Sep 13 2017, 3:57 PM

As mentioned in the release notes, we only support graphics cards with GCN architecture 2.0 and above).