Blender 2.79 Crashes when closing "toggle system console"
Closed, ArchivedPublic

Description

System Information
Windows 10 (Home Version)
i7 2600k
8Gb ram
Geforce GTX 560ti

Blender Version
Broken: 2.79 5bd8ac9
Worked: Not Applicable

Short description of error
Blender Crashes when closing "(toggle) system console"

Exact steps for others to reproduce the error

  1. Open Default 2.79 (5bd8ac9)
  2. In top left of screen (Info) click on "Window"
  3. Click on "Toggle System Console"
  4. Close "System Console" by clicking on "x" (top right of system console window)
  5. Blender immediately crashes

Note:

Accidentally discovered while working with 2.78c file on new 2.79 install.  
Restarted computer and duplicated error several times with default 2.79 file

Details

Type
Bug
Sergey Sharybin (sergey) closed this task as "Archived".Thu, Sep 14, 9:36 AM
Sergey Sharybin (sergey) claimed this task.

This isn't a bug, Blender is a console application (so it can print logs, errors etc to the console) and the way it works is:

  • First console window is opened (it's done by Windows OS)
  • Then Blender creates a GUI window for self, and hides the console
  • Toggle system console shows the console window

To hide the console back, you need to use toggle system console again, which only affects visibility of window. Closing console window with X will indeed terminate the whole Blender, since it's equal to closing the "root" of application.

Thanks for the report, but it's not a bug.

Ahh! Understood.

Thank you, Sergey.