Page MenuHome

Matcap breaks Clipping Border
Closed, ArchivedPublic

Description

System Information
Win7 64 bit
ATI HD4600 series. Display Driver ver. 8.97.100.11. OpenCL(tm) Driver 10.0.937.2

Blender Version
Broken: 2.79c

Exact steps for others to reproduce the error
Open file, check/uncheck Matcap in N-panel

Details

Type
Bug

Event Timeline

Joshua Leung (aligorith) triaged this task as Needs Information from User priority.

Cannot reproduce here.

Sounds like a potential graphics driver problem, though there is insufficient info in this report to figure out what may be going wrong.

Please include the following info (and for all future reports) in addition to what you've got above:

  • Graphics Card, Driver versions, etc.
  • An explanation of what exactly is going wrong - e.g. how is it "breaking" the clipping border? (screenshots in this case would be helpful)

Sorry, totally forgot about videocard.

It is ATI HD4600 series. Display Driver ver. 8.97.100.11. OpenCL(tm) Driver 10.0.937.2


Likely this is an issue with CLIP_WORKAROUND in gpu_shader.c

Likely this is an issue with CLIP_WORKAROUND in gpu_shader.c

If that is the case, I had a similar problem when trying to create shaders for OpenGL version 1.2.
I passed the clip_planes as a uniform:
3D_vert.glsl
primitive_id_frag.gls

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.Oct 10 2017, 9:51 AM
Campbell Barton (campbellbarton) closed this task as Archived.EditedFeb 6 2019, 12:05 AM

Closing since this is resolved in 2.8x and it's unlikely support will be added for 2.7x.