When driven IK influence change, ik animation have 1 frame delay
Closed, ResolvedPublic

Description

System Information
Win10
GTX-1050Ti

Blender Version
Broken: 2.79 5bd8ac9
Worked: (optional)

Short description of error
When IK influence change, ik animation have 1 frame delay
And this delay will be exported

Exact steps for others to reproduce the error
1.The IK Bone influence is driver from another bone
and on the first NLA or frame influence is 0.


2.Hold Alt and scrolling mouse wheel move to next frame.Or press Right Arrow Key move to next frame.The IK target moved and IK Bone have not change.
first frame:

next frame:

3.Export FBX with NLA


4.Import Unity


5.Error blender file and fbx

Sergey Sharybin (sergey) closed this task as "Archived".Thu, Sep 21, 9:49 AM
Sergey Sharybin (sergey) claimed this task.

The IK Bone influence is driver from another bone

This isn't supported by old dependency graph. You need to explicitly enable new dependency graph using --enable-new-depsgraph command line argument.

Thanks for the report, but it's a known limitation of old depsgraph.

I try todo this and the error still here

Are you showing a result of roundtrip of exporting scene from blender to fbx and back to blender?

Sergey Sharybin (sergey) reopened this task as "Open".Thu, Sep 21, 10:39 AM
Sergey Sharybin (sergey) triaged this task as "Incomplete" priority.

@Bastien Montagne (mont29), maybe you can deduct something here already?

Bastien Montagne (mont29) changed the title from "When IK influence change, ik animation have 1 frame delay on export FBX" to "When driven IK influence change, ik animation have 1 frame delay".Thu, Sep 21, 10:56 AM
Bastien Montagne (mont29) removed Bastien Montagne (mont29) as the assignee of this task.
Bastien Montagne (mont29) raised the priority of this task from "Incomplete" to "Confirmed".Thu, Sep 21, 11:02 AM

This has nothing to do with FBX at all, issue is with Blender update somehow. When you move frame forward between both NLA strips shown in pictures above, the right arm of the character does not follow the (now 1.0 influencing) IK target. Going to next frame, or switching to Edit mode and back, updates it correctly.

@Sergey Sharybin (sergey) re-assigning to you, since this is probably an update (depsgraph) issue (missing relation? wrong order, like IK constraint being evaluated before its driven influence is?), but maybe @Joshua Leung (aligorith) has some idea here too? Note that usual tricks (extra object/data updates) do not seem to work here…

@Bastien Montagne (mont29). did you test that with new depsgraph enabled?

@Sergey Sharybin (sergey), yes, tested with both old and new depsgraph, with and without extra updates in both cases, none worked (old depsgraph has different behavior than new one when going backward, though, but neither is correct in that case either).

Here is a simplified file