Page MenuHome

change Image.source in Image Texture does not refresh corretly
Closed, ArchivedPublic

Description

System Information
Win7 64 bits

Blender Version
official 2.79 and blender-2.79-a8f11f5-win64.zip(Mon Sep 25 03:13:13 2017 )

Exact steps for others to reproduce the error

  1. set node for lamp as http://www.creativeshrimp.com/wp-content/uploads/2014/12/texture_02.jpg says, and select a image file form local disk
  2. change "Single Image" in "image texture" to "Generated"
  3. change "Generated" in "image texture" to "Single Image". now the lamp is pink. We have to select the image file on disk again

Details

Type
Bug

Event Timeline

Problem does not occur when source change make sense. "Single Image" to "Image Sequence" or "Movie".

Generated source type is there to create an image from scratch.
It is source type used when you press the + New button.

From a logical point of view, it does not make sense to keep in memory image path to support such changes.
Because a conscious user have no benefit to make this operation.
When you create a new image from scratch, you will save it.
You will not open an image to create a new one to go back to previous one.

But from a pratical point of view, source change can be done by a Ctrl Wheel operation hovering the node.
If wheel is moved in correct sense, you changed image source from "Single Image" to "Image Sequence".
If user turned the wheel in the wrong sense, image source is changed to Generated type and he have to reopen the file.
That's a little UI issue.

LazyDodo (LazyDodo) triaged this task as Confirmed priority.Sep 28 2017, 7:37 PM

Can redo the issue, but unsure if this is expected behavior or not. @Sergey Sharybin (sergey)?

Sergey Sharybin (sergey) closed this task as Archived.Feb 1 2018, 4:52 PM

Changing image source type clears the file path. This prevents accidents like reported in T37718 from being happening.

Maybe it's possible to find a better solution, but that's handled outside of the bug tracker.