JACK sync plays also meta-strips
Closed, ArchivedPublic

Description

System Information
archlinux
jack2 1.9.10-6

Blender Version
version: 2.79 (sub 0), branch: makepkg, commit date: 2017-09-12 08:47, hash: 8ef39d5c882, type: Release
build date: 2017-09-25, 18:40:03
platform: Linux

  • Tested with the official release from blender.org
  • Tested with 2.80 from builder.blender.org

Short description of error
Sync works but when using meta-strips.. Audio is played from all of these..
i.e. I am inside a meta-strip, click play and I ear audio from the meta-strip, root and other metastrips also.

Exact steps for others to reproduce the error
just add two audios, make a metastrips of one of these and put them one over the other. Enter the metastrip and click play.

Details

Type
Bug
ronan ducluzeau (zeauro) closed this task as Archived.Fri, Oct 13, 12:27 PM
ronan ducluzeau (zeauro) claimed this task.

Hi, original purpose of Blender was to produce images from 3D scene.
Historically, there was an audio sequencer decoupled from video sequencer. They were merged by 2.5 re-design.
If you take attention to Edit Strip panel in Metastrip properties, you can see that they are based on Scene, Movie, Image strips properties with a blend mode dedicated to image blending.

Metastrips are not well designed to take into account audio strips properties. A minimal support exists to mute audio strips contained inside muted metastrips.
But without audio properties exposed in metastrip properties, by design, user have no more choïce than entering inside metastrip using tab key to mute audio strip or animate its properties.

Adding more audio properties to support audio mixing is a design issue or a feature request.

While its disputable how this should work, its behaving as intended and not an error in the code.

While we love to hear these ideas, this is not the right place for them. This website is mainly used to track bug reports and not feature requests. But luckly, there are some other nice solutions you can take, so please use one of the other forms of communication listed below:

https://rightclickselect.com/
Fun board mailing list: https://lists.blender.org/mailman/listinfo/bf-funboard