Rigify paw IK stretch error and Legacy Mode "paw" missing
Closed, ResolvedPublic

Description

System Information
Windows 10 Pro, NVIDIA GeForce GTX 1070 (laptop: msi GT72VR 7RE Dominator Pro)
And
Windows 10 Pro, NVIDIA GeForce GTX 960m (laptop: ASUS GL752v)

Blender Version
Broken: 2.79 5bd8ac9
Worked: 2.78c e92f235283 (tested with "pitchipoy.limbs.super_front_paw" and "pitchipoy.limbs.super_rear_paw")

Short description of error
In Rigify addon: Off "IK_Stretch" does not work correctly on Cat's paws, Horse, Wolf, Basic_Quadruped, limbs.paw and limbs.rear_paw.
Also, in "Legacy Mode" there are no paws in "Add sample" (I attached image) :(

Exact steps for others to reproduce the error

  1. Create "Basic_Quadruped".
  2. In "pose mode" move an IK control down.
  3. Set "IK_Stretch" to 0
  4. Verify that "IK_Stretch" is not deactivated correctly.

(This happens in Cat's paw, Horse, Wolf, Basic_Quadruped, limbs.paw and limbs.rear_paw)



Details

Type
Bug
Sergey Sharybin (sergey) triaged this task as Normal priority.Oct 19 2017, 2:40 PM

@Lucio Rossi (luciorossi) , guess you was most active developer of this tool for 2.79, mind having a look? :)

Hi,
I'm investigating the IK_Stretch issue so I'll answer the 2nd question first.

Legacy mode was implemented as a pre-2.78 snapshot of the addon, the functionalities of the "super paws" are replicated and improved in the 2.79 paw limb.

In case you need those rig_types belonging to 2.78c while using rigify in Legacy mode under 2.79, I suggest you to copy-paste the 2.78c rig files (rigify\rigs\pitchipoy\limbs\super_rear_paw.py and rigify\rigs\pitchipoy\limbs\super_front_paw.py) into the rigify\legacy\rigs\pitchipoy\limbs\ directory of 2.79, they should be working without any problem.

In case you have errors after the copy-paste let me know

Many thanks for the advice of copying and pasting the 2.78c platform files. I did it and it works well. (It is very useful to me)

I'm not sure that the spine works well (quadruped rid 2.79). It has only two bones to control the curvature. It is complicated to bend the spine. Sorry for commenting here, I was not sure about reporting this as a bug. Would you mind checking this out?

Thank you very much.

@Luis Miguel Pérez González (Wilson)

I'm not sure that the spine works well (quadruped rid 2.79). It has only two bones to control the curvature. It is complicated to bend the spine. Sorry for commenting here, I was not sure about reporting this as a bug. Would you mind checking this out?

This is by design. All the spines have upper and lower spine controls as main chain effectors, the pivot effector position is customizable. ALl the other deformation have to be handled through tweaks. I can't imagine a different behavior for a spine since it replicates the way a spine works. But i am open to suggestions.

Exact steps for others to reproduce the error

Create "Basic_Quadruped".
In "pose mode" move an IK control down.
Set "IK_Stretch" to 0
Verify that "IK_Stretch" is not deactivated correctly.
(This happens in Cat's paw, Horse, Wolf, Basic_Quadruped, limbs.paw and limbs.rear_paw)

I can conform this issue instead. It seem s related to the paw code itself, from a quick look there's a missing "connected" flag on the MCH-toe_parent bone. Enabling the "connected" flag even after the rig generation seems to fix the problem. I am investigating a permanent fix.

The spine of the cat looks very good. Should the "Basic Quadruped" or wolf spine work in the same way?

I did not find the option to move the pivot point of the spine in the new rigify (2.79). I looked in the documentation too.
In the previous version (2.78) if you could change it in the "Pivot Slide" option. You mean that?
Having that control in the spine would be fantastic.

This is an incredible tool. We are testing it in production. Thank you very much.

(sorry for my bad english)

@Luis Miguel Pérez González (Wilson)

The spine of the cat looks very good. Should the "Basic Quadruped" or wolf spine work in the same way?

indeed it should. And... it isn't. Seems the problem is a prop on the metarig.

I did not find the option to move the pivot point of the spine in the new rigify (2.79). I looked in the documentation too.
In the previous version (2.78) if you could change it in the "Pivot Slide" option. You mean that?

The slider is still there, but is moved on the first bone of the chain (the first tail bone). Just select it and as usual in the bone properties tab - in pose mode - set the pivot to 6. It should work fine then.


about the main thread:

In Rigify addon: Off "IK_Stretch" does not work correctly on Cat's paws, Horse, Wolf, Basic_Quadruped, limbs.paw and limbs.rear_paw.

this should be fixed now. If you want to test it out download our testing version of rigify from Lucio's github page
Rigify Testing Build

  1. Unzip
  2. Rename the folder "rigify"
  3. owerwrite it in your blender addon folder

Great. I tried it and it works.
Thank you very much. :)

Sorry but I can not find the pivot slide. I selected each bone in the spine and tail and found only "head_follow", "neck_follow" and "tail_follow". Could you tell me the name of the bone?

Thank you very much for your time.

@Luis Miguel Pérez González (Wilson)

Sorry but I can not find the pivot slide. I selected each bone in the spine and tail and found only "head_follow", "neck_follow" and "tail_follow". Could you tell me the name of the bone?

you have to do it on the meta-rig and then generate again.

OK perfect. Thank you.
Once created, can the pivot point be modified? (As in version 2.78)

@Luis Miguel Pérez González (Wilson)

Once created, can the pivot point be modified?

No

(As in version 2.78)

i think you refer to the original non-stretchy spine since in the 2.78 the super_torso_turbo had the exact same behavior (plus lots of bug and limitations). That kind of spine has been replaced by the new one as default. The only way of using it for now is enabling the legacy mode and use the old method.

Exactly, I mean how "super_torso_turbo" worked. I was not sure if the new spine had that option.

Thank you for answering so quickly. Everything is alright.

Lucio Rossi (luciorossi) closed this task as Resolved.Oct 25 2017, 7:38 PM