Page MenuHome

Cycles - Texture Painting -Add Paint Slot , texture node disconnected
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

2.79

Short description of error

When i create an object, switch to texture painting and add a texture paint slot, then a material gets created where the texture node is not connected with the diffuse node.

This means you can do texture painting at the added texture. And the changest that you do at the texture will show up in the viewport. But you cannot render it. The material is missing the connection to the texture. Which you have to fix by hand then.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Switch to Cycles, delete standardcube. Create cube. Switch to Texturepainting. Add Texturepaint slot. Switch to Compositing layout. The texture node has no connection to the diffuse node.

Details

Type
Bug

Event Timeline

ronan ducluzeau (zeauro) closed this task as Archived.Oct 8 2017, 11:21 AM
ronan ducluzeau (zeauro) claimed this task.

It is not a bug but a known limitation.

Texture slots support is a feature inspired from an addon created during 2.5x series when Cycles did not exist, yet.
So, texture slots types were thought with Blender Internal textures system in mind where textures are separated from materials/shaders.
But this support was done for 2.72 release when Blender Internal renderer was still render engine by default but Cycles had become really popular.
So, a adaptation to have a quick painting process was done.
https://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.72/Painting#Texture_Slot_Support

Cycles uses a different approach where textures and shaders are nodes, part of a material nodetree.
User could build a nodetree that contains 3 or 4 Diffuse Shader nodes.
If it is the case when user enter in Texture Paint mode, there is a query. Should Diffuse texture created be linked to all diffuse nodes or just to first diffuse node created ?
So, choïce was made to let decision to user and add an Image node without connection.
At first image, add paint slots list menu dissapears with Cycles. It is not the case in Blender Render UI.

Principled Shader have just been added to last release 2.79.
Decision was made to wait a minimal feedback from users before modifying texture slots system to this shader.
But currently, there is a consensus for future 2.8x releases (Blender Internal renderer will be removed for 2.8) that Texture Slots system will be adapted to Principled Shader to give instant feedback in EEVEE and Cycles.