Page MenuHome

Undo doesn't undo the latest Automirror function that was selected!
Closed, ArchivedPublic

Description

System Information

Windows 7

Nvidia Geforce GT620

Blender Version
2.79, Steam, latest

Short description of error

When hitting Undo after, say, the Y axis mirror, hitting Ctrl+Z does not undo the operation.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Simply go to Tools -> Automirror -> Options -> Y -> hit button -> Ctrl+Z

Details

Type
Bug

Event Timeline

ashley (watercolor) updated the task description. (Show Details)
ashley (watercolor) awarded a token.
Sergey Sharybin (sergey) triaged this task as Normal priority.

Sounds like an addon issue to me. Assuming @Lapineige is the author of that addon.

However, might be just a limitation of the undo system, when you mix settings stored in interface and global undo.

I'm not sure of the origin of this issue: If I add 'UNDO' in the bl_options, the Auto Mirror operation can be seen in the Undo History, but undoing it doesn't remove the mirror modifier.
I first thought it was due to global undo, but disabling it doesn't seem to change the final result.
(also using the Last Operator panel doesn't undo the operation, but does it multiple times instead)

@ashley (watercolor): this add-on was first intended to be used from object mode (which is the most common case), then I allowed edit mode but probably never tested that case of undoing inside edit mode. That's why I didn't see this problem.
Until this is fixed, if you have global undo activated, swap to object mode and then use AutoMirror. Then you should be able to undo it (from object mode) without undoing previous changes you made.

@ashley (watercolor): this add-on was first intended to be used from object mode (which is the most common case), then I allowed edit mode but probably never tested that case of undoing inside edit mode. That's why I didn't see this problem.
Until this is fixed, if you have global undo activated, swap to object mode and then use AutoMirror. Then you should be able to undo it (from object mode) without undoing previous changes you made.

Lapineige, thank you for taking the time to look at this. I started using Blender about ... a day ago so some of this functionality is opaque to me.

I did try this in Edit Mode just now, with the same result? After a quick google, it seems Global Undo is active. Hmm...

Lapineige added a comment.EditedOct 16 2017, 7:23 PM

I did try this in Edit Mode just now, with the same result?

No, apply it from object mode, and then go back to object mode (it should put you in edit mode) to cancel the operation (you can do it thanks to Global Undo).

Lapineige closed this task as Archived.Oct 28 2018, 11:31 AM

I couldn't fix this issue, making my add-on usable with undo system was breaking some of its features.
This add-on is being rewritten for Blender 2.8x, hopefully I will figure out a way to fix that.

I guess we can close this issue now.