Crash when changing the engine to Eevee
Closed, ResolvedPublic

Description

System Information
Windows 10 - 64bits
renderer: AMD Radeon HD 7500M/7600M Series
openGL version: 4.5.13399 Core Profile Context 0

Blender Version
Blender 2.8
hash: 8ffb76138731d6241a6ac5bfc17bb764cfa59053

Short description of error
If you change the engine from Eevee to Clay or Cycles and then return to Eevee, a Crash with the following message occurs:

Exception thrown at 0x000000006E216906 (atio6axx.dll) in blender.exe: 0xC0000005: Access violation reading location 0x0000000000000008. occurred

The same does not happen if you change the engine to Blender Render and go back to Eevee. You must have started Cycles or Clay at least once.

Here an image showing the call stack:

And here's the backtrace:

Details

Type
Bug

@Germano Cavalcante (mano-wii)
Could you try running blender with the --debug-gpu and --debug-gpu-shaders and report any errors that come up from those? IIRC, in previous cases of crashes, it's been due to the drivers/GLSL compilers not liking some or other construct in the shaders.

Joshua Leung (aligorith) triaged this task as Incomplete priority.Oct 17 2017, 6:10 AM

@Joshua Leung (aligorith)
Good sugestion. The generated log seems very clear :)
After much and much line, there is this part:

Bastien Montagne (mont29) raised the priority of this task from Incomplete to Normal.Oct 31 2017, 4:08 PM
Clément Foucault (fclem) closed this task as Resolved.Nov 1 2017, 4:15 PM

Fixed by removing unecessary downsampling of minzbuffer in 345ffe3e4d9f.

Cause of the issue is still uncertain.