Page MenuHome

Blender crashes / stops complete system
Closed, ArchivedPublic

Description

System Information

  1. Windows 10 Home plus Geforce Titan
  2. Windows 10 Home plus Geforce 1080

Blender Version
Broken: 2.79, 2017-09-11 10:43
Worked: (optional)

Short description of error
Trying to render the attached scene completely stops both computers. No more mouse move, no light switch on NumLock key, only reboot possible.

Exact steps for others to reproduce the error
Load the file and press F12

Details

Type
Bug

Event Timeline

I'm not a developer
Its probably the extreme volume sampling, and light bounces for volumes, could your cards normally handle that ??
I rendered CPU and it did not crash, system stayed responsive, but had to kill blender cause such tasks take to much time, but windows was responsive.
I can imagine since windows wants drivers to be responsive this loaded to much work on your cards, and system gave up on the drivers, and your system came in a halt.
Halts are notorious to debug, but i would think the cause is obvious here.. remind that volume is one of the most time expensive shaders to use.

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

This is basically a known limitation of branched path tracing on the GPU, that we want to try solving at some point but will require deep changes. If you render with 200 volume samples, that will keep the GPU busy for way too long and freeze everything else in the system.

Normally, Windows is configured to time out after 2s if this happens, after which rendering should fail. Did you by any chance disable this timeout? If so that's basically the risk you're taking, to have your system freeze when rendering these kinds of scenes.

I suggest to use more AA samples and fewer other samples, or switch to regular path tracing. We do support branched path tracing on the GPU, but it's really not designed for that.

Just dropping a comment to verify a similar issue with branched with volume rendering. Render dies at 256 samples on volume, giving "CUDA error: Launch failed in cuCtxSynchronize(), line 1372" on a simple scene. The volume uses a musgrave node on Volume Scatter on a Add Shader with Absorption in a Cornell Box scene. As Brecht said, it dies after 2 seconds. Using 4GB GTX Geforce 1050 Ti.

[EDIT] Someone on Discord suggested lowering the tile size, the crash doesn't happen when set to 32. Super slow render though.

Sorry for my late reply. I just discovered the notification mail in my spam file.
I'm using the default settings of the graphics adapter. Sometimes before, I received the CUDA error mentioned by Elon, but not in this case. So I will proceed as Brecht suggests and will try to use "mist" instead of volume.
Thanks everybody for the investigation!