Page MenuHome

Image texture node, sequence doesnt preview in viewport
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: (example: 2.79 5bd8ac9)

Short description of error

Exact steps for others to reproduce the error
In VSE create a movie from an image strip, render to movie, then it wil output 001-008.mkv (8 images or so).

In another blend file (or on a different layer) :
In cycles use this mkv as movie sequence, for the texture node.
Assign texture node to emission object, and put it to a plane (or use addon pictures to planes).

you can use offset or start frame, or move to a specific time on the strip, but the texture out in image seqeunce stays at the first picture.
In rendering it seams to work, but it doesnt work in viewport mode, so if one tried to show a few pictures or wants to sync to some specific time (ea animating the of set), isnt workable in viewport.

Related Objects

Event Timeline

It may be just default preferences for Timeline Editor that are the reason of problem.

By default, editors enabled under Playback menu of Timeline Editor are All 3D Views and Animation Editors.
https://docs.blender.org/manual/en/dev/editors/timeline.html#playback-menu

But it is not sufficient. You have to enable Property Editors checkbox , too in order to see an image sequence updated in viewport.
Properties to refresh the image are dependent of this editor.

Is it the case ?

No, or if it should then its not working, neither for mkv movie or jpg image series.
Not for CPU and not for GPU (if only CPU worked would allready be fine to me).

ronan ducluzeau (zeauro) triaged this task as Needs Information from User priority.Oct 27 2017, 1:48 PM

I still does not manage to reproduce the issue under linux. For me, when it works for rendering, it works in viewport.

Please, provide info required by template (Operating system and graphics card, blender version that is broken, last version when it worked...) .

It would be helpful if you add mkv created or little jpg image serie and a blend-file to the report that demonstrates the issue at hand.

Marking as "Incomplete" until the requested information/data is provided.