import a fbx then export a dae file, blender crashed, (always)
Open, ConfirmedPublic

Description

System Information
macOS 10.13.1
iMac late 2013

Blender Version
version 2.79

Worked: (optional)

Short description of error
import a fbx then export a dae file, blender crashed, (always)

Exact steps for others to reproduce the error

  1. open blender
  2. remove box
  3. import a fbx
  4. export to dae
  5. crash

crash log:

model sample:

Details

Type
Bug

I couldnt even open the fbx file, i am not a developer but in some cases i give advice that can help you and them

You see its complex to keep up with company formats if those companies dont support open formats (like DocX), basically its all reversed engineering whats in Blender.
I think you better go with the tools provided by those companies to convert those files; checkout this : https://www.autodesk.com/products/fbx/fbx-review
Blender will never be a state of the art converter of autocad formats, simply because they dont put their format under open document contract licenses.
Also they are prone to change some of their formats so that different versions of autocad itself cannot even exchange files, just to drive up their sales...

I'd say yes its a bug, but dont blame the people who try to reverse engineer it, and always in such cases try to find the company and check if they do conversions.
Some developers try to reverse engineer their formats with some degree of succes, but since its not open its always a trouble.
So great if it got fixed but dont count of it, as reverse engineering is a enormous task. But i hope that the link will help you in your process.

I couldnt even open the fbx file, i am not a developer but in some cases i give advice that can help you and them

You see its complex to keep up with company formats if those companies dont support open formats (like DocX), basically its all reversed engineering whats in Blender.
I think you better go with the tools provided by those companies to convert those files; checkout this : https://www.autodesk.com/products/fbx/fbx-review
Blender will never be a state of the art converter of autocad formats, simply because they dont put their format under open document contract licenses.
Also they are prone to change some of their formats so that different versions of autocad itself cannot even exchange files, just to drive up their sales...

I'd say yes its a bug, but dont blame the people who try to reverse engineer it, and always in such cases try to find the company and check if they do conversions.
Some developers try to reverse engineer their formats with some degree of succes, but since its not open its always a trouble.
So great if it got fixed but dont count of it, as reverse engineering is a enormous task. But i hope that the link will help you in your process.

sample fbx file can open with “autodesk fbx review” app

Joel Godin (FloridaJo) triaged this task as Confirmed priority.Fri, Nov 3, 11:17 AM

Happens here on OSX as well. Oct 24 build.
crash log here:

Is this yours @Gaia Clary (gaiaclary) ?

Please can you create a blend file that will crash blender when you try to export it to dae ?
Then prepare the blend file such that all i need to do is calling:

File -> Export -> Collada -> Export Collada

to see blender crashing.
I just want to be sure that i am looking at the right thing.
Then its much easier to figure out what is wrong :)

thanks

Gaia Clary (gaiaclary) closed this task as Invalid.Fri, Nov 3, 12:13 PM
Gaia Clary (gaiaclary) reopened this task as Open.
Gaia Clary (gaiaclary) lowered the priority of this task from Confirmed to Incomplete.

If I pack external data, it no longer crashes.
You have to import, then export > crash.
If you import, pack, export, > no crash.

Joel Godin (FloridaJo) raised the priority of this task from Incomplete to Confirmed.Sat, Nov 4, 5:36 PM