Page MenuHome

NLA's "animated strip time" greying out playback scale
Closed, InvalidPublic

Description

System Information
Win7 64bit

Blender Version
Broken: 2.79

Short description of error
Cube is moving on Y axis from frame 1 to 50. This action was pushed in NLA and I altered strip via Animated Strip Time like this: frames 1-50 use 1-15 of original action, then action idles and go rapidly to the end.

I don't understand why it is greyed out, you still can change this value and it is affecting animation quite well.

Exact steps for others to reproduce the error
Create some action, push it in NLA, enable Animated Strip Time -> greyed out playback scale
Or .blend

Details

Type
Bug

Event Timeline

Joshua Leung (aligorith) closed this task as Invalid.
Joshua Leung (aligorith) claimed this task.

Not a bug.

While the scale/repeat settings can still be used to change the length of the strip, they no longer affect how the keyframes from the referenced action are mapped to fill that strip. For that reason, they are greyed out to indicate that changing them will have no effect on how the playback occurs - for example, with your example file, setting the scale to 10 won't make everything run 10 times faster/slower, as that setting doesn't affect the "Strip Time" F-Curve at all.

What's happening is that once you enable the "Animated Strip Time", the NLA system uses the "Strip Time" F-Curve to determine what frame from the action should be played when frame x of strip is encountered.

However, when this option is disabled, the NLA system uses the Scale & Repeat settings to determine how this mapping takes place (i.e. basically, instead of using the curve you provide, it automatically calculates a saw-tooth shaped one for you based on those settings):

  • the "Scale" setting determines how long each cycle/chunk lasts (relative to the length of the action),
  • the "Repeat" setting determines how many times the chunks/cycles get repeated over the length of the strip.

But if you change scale in opposite direction, like <2 it does affect keyframe values of Animated Strip Time.