Page MenuHome

Baking particle system produces no result
Closed, ArchivedPublic

Description

System Information
Win 8.1x64, 3x gtx580,
Ubuntu14x64, Intel gma

Blender Version
2.79

Short description of error
Pressing bake on particle system bakes empty cache, while unbaked playback acts normal.
Acts the same on both Windows and Ubuntu.
Has something to do with particular file, which I unfortunately saved as default, however deleting everything and creating a new particle system doesn't help, which leads to idea that there likely to be a bug.

Exact steps for others to reproduce the error

  • Open
  • Press bake
  • Cache is now locked, but empty

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Normal priority.

This is weird… With that .blend file, no way to get any baked cache for particles, even with a brand new object & particles system. During baking, objects generating particles have no 'UPDATE' flag set at all, so they are not recomputed for any frame, hence no particles to put in cache… And this happens with both depsgraphes.

With startup .blend file though, no problem at all, everything works as expected.

@Sergey Sharybin (sergey), it seems to be related to object update flags somehow, maybe you can understand what’s happening here better than me?

Baking is relative to active scene layers. I think it is expected behaviour in order to manage baking in files containing multiples simulations.

3D View layers are not the same than scene layers in .blend file.
Object is in a scene layer disabled in Render Layers tab.

If you scene layer is enabled, baking is working in attached .blend file.

"I think it is expected behaviour in order to manage baking in files containing multiples simulations."
Not really, because it's a Bake button of a concrete object not the scene. That is - it is there to explicitly bake a concrete object and it can't do anything else.

You are right. It could be only pertinent for Bake All Dynamics button.
I don't know if code ever made a difference between Bake button and Bake All Dynamics one about layer restriction.

If developers don't have time or don't see advantage to add one, it could be simply mentionned in manual as a known limitation, a little check to do by the user.

@Bastien Montagne (mont29), not sure it worth time understanding all those legacy particle flags. I'd rather encourage the node-based particles project than to spend time on something which is not really a regression.

Bastien Montagne (mont29) closed this task as Archived.Jan 25 2019, 4:58 PM
Bastien Montagne (mont29) claimed this task.

@Sergey Sharybin (sergey) agreed, time to archive this as 'known limitation' then I guess. :)