Page MenuHome

Layers buttons are often lost from the 3D View's Header when exiting edit mode
Closed, InvalidPublic

Description

*System Information**
OSX 10.13
NVIDIA GeForce GT 755M 1 GB

Blender Version
Broken: 2.79
Worked: Never? spotted it about 7 years ago, but only just around to filing this!

Short description of error
Layers buttons are often lost from the 3D View's Header when exiting edit mode - when going back to object mode after editing an object, the layers toggle buttons are sometimes simply not there!

Exact steps for others to reproduce the error
Apologies, this is another bug where I do not know exactly when it happens, so is hard for me to give instructions to reproduce, but again, it has been observed for multiple years, on multiple hardwares running multiple operating systems, so I am certain that it is just a Blender 'thing' that I now simply just work around - There is a definite work around too - all you need to do is create another 3d view with the corner grabber, and you will see that this new window's header has the layers buttons! So, make this new view and kill the old view, and you're back in business.
Thanks
Wayne

Details

Type
Bug

Event Timeline

Also OSX here, but have never seen that.

ronan ducluzeau (zeauro) closed this task as Invalid.Nov 6 2017, 2:58 PM
ronan ducluzeau (zeauro) claimed this task.

If you find an error in Blender you need to report exactly what fails and how to redo the bug.

However this is not a bug report we can handle usefully.

It could simply be a mishandling that enables Local View which is a feature.
https://docs.blender.org/manual/en/dev/editors/3dview/navigate/views.html#view-global-local


Here's a vid, hopefully will help explain, but still not how to reproduce :l This is actually happening in the default, non maximised 3d view now - I always thought it was only when in a maximised view, but perhaps it is to do with the wider field of view when maximised that makes it more prone to happen?