FBX export resets Rigify root/parent and IK_Stretch sliders to their defaults
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10
Graphics card: 2 x nVIDIA GeForce GTX 780 (in SLI)

Blender Version
Broken: 2.79

Upon exporting a file as FBX, the "root/parent" and "IK_Stretch" sliders in the Rigify armature get reset to their defaults.

  • root/parent gets reset from 1.0 to 0.0
  • IK_Stretch gets reset from 0.0 to 1.0

Exact steps for others to reproduce the error

  1. Open the attached blend file
  2. Select the "hand_ik.L" bone in the armature
  3. Play the animation "Walk", notice how the left arm moves with the body (root/parent is set to 1.0)
  4. File -> Export -> FBX (default settings)
  5. Play the animation now: the slider root/parent is reset to 0.0 and IK_Strech is reset to 1.0

Expected behavior
Exporting a file as FBX shouldn't alter anything in the armature / rig / animation.

Details

Type
Bug

Hello,

Can't reproduce here (Windows 10, 2.79). Sliders did'nt change after export.

Hi, Did you look at the "hand_ik.L" bone specifically? The other side seems to be working fine.

Julien DUROURE (julien) triaged this task as Incomplete priority.Tue, Nov 14, 8:24 AM

Hello,

Yes, I checked with "hand_ik.L", that is your active bone on provided file.

David N (sirseko) closed this task as Invalid.Wed, Nov 22, 4:50 PM
David N (sirseko) claimed this task.

Thanks, let me set my report to Invalid in that case. If you can't reproduce it then it might be something else that's messed up on my end. Thanks for your time.