Drop in rendering performance if result in image window set to stereo 3D
Open, Needs TriagePublic

Description

System Information
Windows 7 Pro
NVidia Quadro P6000

Blender Version
Broken: 2.79, also more recent daily builds.

Short description of error
When rendering a stereo image (or even more when rendering a stereo panorama), and showing the results in the image editor in 3D (enable the button with the anaglyph glasses on it), Blender slows down to a crawl. CPU usage does not reach 100%, hovers around 30%. If I instead start rendering and minimize the window, then it renders fast, and uses 100% CPU. Or if I leave Blender open, and disable the 3D results view, but just display either the left or right side, then it also renders fast.

With increasing geometry and increasing resolution, the effect is more pronounced. I noticed this in a production scene that I started to render over night. When I came the next day, it had rendered for 13 hours, but still wasn't done with the first eye. Then I minimized the window, and so it finished the left eye and then did the right eye, all in about the next 1,5 hours. That means a tenfold decrease in performance!

Exact steps for others to reproduce the error
I have a simple blend file attached. It is set to a high resolution.

  • Hit render, leave window open, note the time. I get about 8 Minutes with my faster PC.
  • Then disable the 3D results view in the header of the image editor (button with the red/cyan glasses), render again. I get 2 minutes.

Setting the resolution to 50% renders faster, the difference is smaller, but still there (50% more time).

Details

Type
Bug