Save User Settings does not save theme edits to the theme itself, only the theme colors applied in the scene
Closed, ArchivedPublic

Description

System Information
Win8, GTX1070

Blender Version
Broken: 2.79 (3f614cd)

Short description of error

Save User Settings does not save theme edits to the theme itself, only the theme colors applied in the scene. I lost some work when creating a theme. This is beause I expected things to work like this:

  1. Create a new theme using the Add (plus) button.
  2. Edit the theme.
  3. Save the results using Save User Settings.

But when I had made some edits, changed to a different theme to see how they looked, then chose my theme preset again my edits were gone. So I'm guessing the current (strange) theme workflow is this:

  1. Edit the theme colors.
  2. Save the theme using the Add (plus) button (which makes no sense)
  3. Save the current applied theme colors (not the theme itself) to the scene using Save User Settings.

It gets even stranger when you want to update your theme, you have to click the Add button and type the same name.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

  1. Create a new theme.
  2. Edit the theme.
  3. Press Save User Settings.
  4. Switch to another theme.
  5. Switch back to your theme. The edits are gone.

If theme settings are in fact user settings (themes is a tab in User Preferences) then they should be saved when pressing Save User Settings.

Details

Type
Bug
ronan ducluzeau (zeauro) closed this task as Archived.Wed, Nov 15, 3:08 PM
ronan ducluzeau (zeauro) claimed this task.

You are looking for an "edit and save" theme feature that does not exist. Blender re-uses its preset system to save themes.
https://docs.blender.org/manual/en/dev/preferences/themes.html
https://docs.blender.org/manual/en/dev/interface/controls/templates/list_presets.html#presets

So, there are presets lists everywhere in blender (camera presets, render presets, encoding presets, cloth presets, ...).
In those cases, it is not weird to create a preset when settings are a few and to validate that choïce by a unique and simple preset creation.
Preset are .py or .xml files that are easily editable in a text editor. So there is no need to create an edition system for that.
In order to save time and efforts, presets system was choosen to register themes and keymap configurations.
In theory, you can edit the xml file corresponding to the theme. And changes will be updated if Preset used has been saved in userpref.blend file.
When you are changing colors and save preferences, you are just modifying the default theme of userpref.blend file but not for the theme preset.

You could edit the theme by selecting the preset, deleting it, changing settings and recreate it.
But in practice, it is safer to simply create a new iteration and simply add an incremental suffix.

While it is disputable how this should work, it is behaving as intended and not an error in the code.

A recent work was done on application template in 2.79. Work on workspace in 2.8 will imply to take a look to user preferences.

While we love to hear these ideas, this is not the right place for them. This website is mainly used to track bug reports and not feature requests. But luckly, there are some other nice solutions you can take, so please use one of the other forms of communication listed below:

https://rightclickselect.com/
Fun board mailing list: https://lists.blender.org/mailman/listinfo/bf-funboard