Eve still requires: werkzeug
Closed, ResolvedPublic


Blender Version
Broken: rPSd66bfe6166be8fa13c2111457e765ea938d054e6
Worked: rPSd66bfe6166be8fa13c2111457e765ea938d054e6^

Short description of error

I can't run setup.py in any pillar extension or use any command entry-point that relies on it (e.g., translations update for dillo or simply python setup.py develop in pillar) because of dependency clashes in pillar.

More details

Eve (0.73 or even its master) still requires: werkzeug>=0.9.4,<=0.11.15' (from https://github.com/pyeve/eve/blob/master/setup.py#L12)

Although the strictly reported issue was addressed, we still have issues with another dependency.
To reproduce: python setup.py develop

error: MarkupSafe 1.0 is installed but markupsafe<1.0,>=0.23 is required by {'Eve'}