Page MenuHome

Weird bug with Particle Instance Modifier
Closed, ResolvedPublic

Description

System Information
Win 10 x64, nVidia GTX 1080Ti

Blender Version
Broken: All
Worked: (optional)

Short description of error
I have a very weird bug with the Particle Instance Modifier. In the OpenGL viewport, rendered view and when rendering in the GUI (F12) everything renders fine, but when rendering via command line or on the farm (with cgru, i.e. a farm software rendering with the command line), the instances are located at the wrong place.

I use a very simple hair emitter to instance meshes along the strands using the "Create along Paths" option. It works very nicely and interactively in the viewport but fails in a very weird way as soon as I send my scene on the farm. I attached a simplified version of the scene and hope it can be fixed.

Exact steps for others to reproduce the error

  • Load this blend file:

  • Press F12 to render. It looks like this:

  • Now call the same render via command line. It should work like this, you will have to change the paths:
blender -b "E:\Instance_Bug_v01.blend" -o "E:\Instance_Bug.#" -s 1 -e 1 -a"
  • This is the result:

  • All the instances now start from the origin of the scene (at least in this example). And they also have weird velocity vectors.

P.S.: Here are the motion vectors when rendering with the command line. There is no animation or deformation on these instances whatsoever, when rendering in the GUI the motion vector pass is totally neutral / empty:

Details

Type
Bug

Event Timeline

Found two other bugs already while trying to confirm yours… :/

Thanks, I actually had render crashes in this project, but it was too weird to reproduce easily. Also I am currently too swamped with work. Hopefully you can kill all these bugs ;)

Sebastian Parborg (zeddb) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

This seems to still be a problem with the latest blender 2.8 beta.

@Sebastian Parborg (zeddb), i can not reproduce the issue here, but i can currently only render on CPU. Does it happen when file is re-saved with CPU settings for you?

@Sergey Sharybin (sergey) it seem like it can not longer reproduce the issue on my end with either blender 2.8 or blender 2.79 :S

I don't know how I managed to reproduce this yesterday...
Should we just mark this as resolved?

@Steffen Dünner (SteffenD), do you mind testing latest build from builder.blender.org?

@Steffen Dünner (SteffenD), do you mind testing latest build from builder.blender.org?

I just did (actually I tried an own build of the very latest 2.7 on Linux Mint) and the result is still the very same as back then.
Here is what it looks like:

OK, just tried it and it works. New dependency graph?

Sergey Sharybin (sergey) closed this task as Resolved.Feb 7 2019, 10:19 AM

Might be new dependency graph, might be fix in some other area. If the issue is fixed in blender2.8, i'd consider this resolved :)