Page MenuHome

Keyframes on particle system settings
Closed, InvalidPublic

Description

System Information
iMac with MacOS 10.13.1
ATI Radeon HD 6970M graphics

Blender Version
Broken: 2.79
Worked: (optional)

Short description of error
When working with particle systems, it is impossible to keyframe the values in the particle settings. They will be marked as keyframed (with coloured text fields), but when you input a new value, it immediately jumps resets to it's old value. Tried this on different Macs, I don't have access to a Windows machine.

Exact steps for others to reproduce the error

In the attached blend file, try to keyframe the rotation of the planes on the sphere with the phase value in the Rotation tab. I am able to insert an initial keyframe, but it is impossible to change the value afterwards, even with the graph editor.

Details

Type
Bug

Event Timeline

This report can be considered as a duplicate of T47080 . To simplify, none of settings related to initial state (Emission, Initial Velocity, Initial Rotation) can be animated.
There is a warning only for some settings and first keyframe insertion is not prohibited for all of them.
So, clarification in User Interface is still a TODO that should be solved during 2.8 development.

Currently, if you want to animate particles rotation, you have to animate rotation of dupli-objects or force fields instead of particles ones.
Or you have to use Emitter particles with a Newtonian physics type and use dynamic angular velocity.

ronan ducluzeau (zeauro) claimed this task.