Page MenuHome

Minpixels for strand rendering crushes blender in CPU mode
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card
Win7 x64 and Win10 x64
GTX1080
Intel Core i7-5930k

Blender Version
Broken: 2.79 Date 2017-09-11 5bd8ac9

Short description of error
When i use minpixels value of 1(or around 1) for strand rendering blender crushes when i render with CPU

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

in attached blend file just hit render when set to CPU render it crashes
if i set it to GPU it renders fine
if i set minpixels bellow 0.5 it renders fine
if i remove 'background' object to another layer it renders fine
if i uncheck 'render Emitter' in particle settings of the 'Ground' object it renders fine
if i render with resolution 2048x2048 it renders fine, however 4096x4096 and 1024x1024 crashes
i tought it could be due to the panoramic fisheye camera but it crashes even when set to perspective camera(though you have to uncheck render border option)

Details

Type
Bug

Event Timeline

Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.

This issue should be fixed in latest builds already. So test blender from builder.blender.org and see if the issue happens there.

Thanks. It works fine in a daily build

This issue should be fixed in latest builds already. So test blender from builder.blender.org and see if the issue happens there.

ronan ducluzeau (zeauro) closed this task as Resolved.Nov 23 2017, 1:42 PM
ronan ducluzeau (zeauro) claimed this task.