Scenes saved with dual screen layout can't be reopened
Closed, ArchivedPublic

Description

Windows 10 x64, 2×NVIDA GTX Titan Black 6Gb, 2×Intel E5-2690, 64GB RAM

Blender 2.79 (sub 0)

When a scene has been saved with two windows (as when you shift-drag the split-panel widget and drag the new window to a second monitor) it cannot be opened from the default scene.

To reproduce:

  1. Shift-drag a split-window widget in the default scene.
  2. Drag the new window to a second monitor.
  3. Save the scene
  4. quit, then restart Blender
  5. open the saved scene

Expected:
scene opens either with both windows or single window

Observed:
Crash with message: Error: EXCEPTION_ACCESS_VIOLATION.
If a scene with two windows has been saved as the default scene, then Blender will not start properly - it crashes as soon as it loads the default scene.

There is a workaround, which is to split the windows before opening the file. This won't work if the default scene has been saved with a split window.

Details

Type
Bug
Vuk Gardašević (lijenstina) triaged this task as Incomplete priority.EditedDec 5 2017, 6:16 AM

Possibly similar issue was reported in T52936.

Please can you check the latest build appropriate for your system from https://builder.blender.org/download/ to see if the error is still present?
There was a commit that addressed some possible related issues. Thanks.

Marking as Incomplete until the requested information/data is provided.

Thanks,
I downloaded blender-2.79.0-git.1802d14-windows64, same behaviour. A dump of the console here:
https://gist.github.com/stibinator/700a4a7a5a739b602d95865962259989

Vuk Gardašević (lijenstina) raised the priority of this task from Incomplete to Needs Triage.Dec 5 2017, 7:25 AM

It seems likely that Python has failed to properly initialize. Could you paste a full log of the initialization?

Campbell Barton (campbellbarton) triaged this task as Incomplete priority.

@Campbell Barton (campbellbarton) no problem. Where are the logs usually stored?

@stib (stib) they aren't - but you managed to post a dump of the console, assume a complete version of this is whats needed.

See: https://docs.blender.org/manual/en/dev/render/workflows/command_line.html

Philipp Oeser (lichtwerk) closed this task as Archived.Jun 20 2018, 4:16 PM

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.

stib (stib) added a comment.EditedJun 21 2018, 4:52 AM

I've done my best to create a log of this happening, for some reaon I'm not seeing the python traceback when it crashes any more, but it happens reliably every time. If anyone can point me to some documentation on how to get a more verbose log, I'm happy to oblige.

Here's me opening a default scene that has been saved with two windows active, and crashing.

> & 'C:\Program Files\Blender Foundation\Blender\blender.exe' -d
Switching to fully guarded memory allocator.
Blender 2.79 (sub 0)
Build: Thu 03/22/2018 09:59 AM Windows
argv[0] = C:\Program Files\Blender Foundation\Blender\blender.exe
argv[1] = -d
read file C:\Users\stib\AppData\Roaming\Blender Foundation\Blender\2.79\config\userpref.blend
  Version 279 sub 0 date 2018-03-22 14:10 hash f4dc9f9d68b
Read prefs: C:\Users\stib\AppData\Roaming\Blender Foundation\Blender\2.79\config\userpref.blend
read file C:\Users\stib\AppData\Roaming\Blender Foundation\Blender\2.79\config\startup.blend
  Version 279 sub 0 date 2018-03-22 14:10 hash f4dc9f9d68b

ordered
 OBCube
 OBLamp
 OBCamera
found bundled python: C:\Program Files\Blender Foundation\Blender\2.79\python
Registered Animation Nodes with 497 modules.
Read blend: C:\Users\stib\Desktop\untitled.blend
read file C:\Users\stib\Desktop\untitled.blend
  Version 279 sub 0 date 2018-03-22 14:10 hash f4dc9f9d68b

ordered
 OBCube
 OBLamp
 OBCamera
Win32 Error# (3221692624): <no system message>
Error: EXCEPTION_ACCESS_VIOLATION