Crash removing object when it exists in disabled collection
Closed, ResolvedPublic

Description

In the attached file, right click on the camera in the outliner and delete it.

Blender crashes: Attempt to free NULL pointer

Details

Type
Bug

This is really strange. Even more strange and potentially related:

  • Apply the patches P569 and P570.
  • Run the new tests: ctest -R view_layer_collection_disable.

The test view_layer_collection_disable_a pass and view_layer_collection_disable_b fails.
The b test fails because the ID* passed to rna_LayerCollection_enable_set is NULL.

However the difference between them is :

- # Workaround required, see collection_disable_b for simplest test.
- bpy.context.layer_collection.enable_set(False)
- bpy.context.layer_collection.enable_set(True)

I suspect this may be an RNA bug.

Sergey Sharybin (sergey) triaged this task as Confirmed priority.Dec 7 2017, 2:57 PM
Dalai Felinto (dfelinto) closed this task as Resolved.Mar 14 2018, 5:51 PM

Fixed already.