Page MenuHome

Lose wacom presure when use two windows.
Open, NormalPublic

Description

System Information
Windows 7 64bits
Two monitors

Blender Version
2.79
It's broken since I remember, only that I ignored the problem.

Short description of error
When you uses multiple windows in same blender instance and a wacom tablet blender lost the pressure or "focus" of the wacom and only go back when you click in the secondary window. And sometimes blender don't paint the grease pencils

The bug affect to painting modes, sculpt, and grease pencil drawing. The problem, that I was ignored because click in the secondary window to obtain presure is not a big problem. But now I have see that also you can have problems with grease pencil, creating "invisible" strokes that don't work with bsurfaces. Blocking the workflow until you "imagine" the problem or close and open blender other time.

Exact steps for others to reproduce the error

  • Open Blender and create a secondary window with 3D view (in my test work with other panels themes)
  • Click in the secondary window
  • Open other program, browser for example (chrome)
  • hide the secondary window
  • focus in chrome
  • focus in primary 3D view
  • Try to paint

Notes:
-In my test it works with windows in different or same monitor, I don't know if it affects to the problem.
-Some times it doesn't work and you must try so iterations of Blender -> Chrome ->Blender -> hide secondary. But I obtain it making few iterations, in less that one minute

Details

Type
Bug

Event Timeline

<SPAMMER> (pati5202) closed this task as Resolved.
This comment was removed by Bastien Montagne (mont29).
Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.Jan 5 2018, 8:29 PM

I cant seem to be able to reproduce this (but I am on linux gnome). Could you confirm this on other machines? Does this happen on other OSes as well?

I have never tried two monitors/windows in linux or macOS. But I can confirm this in Windows 7 64bits in a lot of machines and configurations.

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Normal.Jan 6 2018, 11:28 AM

note that I only tested this with one monitor, still possible this happens with two (but report mentioned this also fails with only one monitor)
A bit speculative, but tagging as windows until someone can reproduce elsewhere...

After some test I can't reproduce with one monitor in macOS, so probably is only a problem in windows systems.