RIGIFY looses Hand and Feet IK Widgets / Crazyspace happening when Rig is Applied / Constraints and Drivers lost after Update Rig
Closed, InvalidPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

Short description of error

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Hi, I am working with Rigify, but I will report several Problems with it here.

The Rig looses the Hand and Feet IK Widgets seemingly random from time to time.
I tried to regenerate the Rig and force the Widgetupdate, but it didnt work.
It's a little frustrating but I found out how to delete the widget from being used, so I at least can see the bone, but it's still curious, because other Bones like the one on the hand where you can change how much spread it is has gone missing too. I thought I'd report this so you know.

The second thing; I have some serious Crazy Space happening when I'm working With Shape Keys. I know the Method in the File attached is shit but it doesn't happen to the mesh when armature deform is disabled. The vertexes are on The Neck and the Tummy (hard to miss on the neck)

A thing I wish for improvements on this addon: When you update the Rig from your Metarig, please let the Constraints and Drivers of the stay intact or please implement an option to do so.. it's quite a task to type them in.

Thank you I hope this finds you well :)

Greez
Luca

Details

Type
Bug

Hi @Luca Egloff (5ucAyman)

You should provide a better explanation of the steps to reproduce the problem (along with system info and blender ver., OS ver. and so on. Copy-pasting the description draft is not enough).
When you provide a .blend it should be as "clean" as possible, meaning: getting rid of any unnecessary elements like drivers, animations, custom properties, text files and so on.
This is useful for three main reasons:

  • easing the bug finding and (maybe) fixing job of devs
  • when you try and make this rollback effort, whatever error in the rigging&animation process you may have done, comes out clear
  • it is easier to point out at what exact point the alleged bug manifests itself and give a better steps-to-reproduce-the-error list

Remember, this is a bug-tracking forum, so users should be reasonably sure they stumbled into an actual bug

LazyDodo (LazyDodo) triaged this task as Incomplete priority.Jan 25 2018, 3:22 PM
LazyDodo (LazyDodo) renamed this task from RIGIFY ------------ looses Hand and Feet IK Widgets / Crazyspace happening when Rig is Applied / Constraints and Drivers lost after Update Rig to RIGIFY looses Hand and Feet IK Widgets / Crazyspace happening when Rig is Applied / Constraints and Drivers lost after Update Rig.

Hi @Luca Egloff (5ucAyman)

I had a look at PandaBeast Woman8.r.blend, "Maximum Draw Type" is set to "Solid" for your rig.

When you use wireframe widgets you have to set the drawing of your rig to wireframe, otherwise you won't be able to see the controls unless the rig is selected.

Cheers,
Paolo

Paolo Acampora (pkrime) closed this task as Invalid.Jan 25 2018, 5:33 PM

I have some serious Crazy Space happening when I'm working With Shape Keys

sculpting on a mesh deformed by an armature is problematic in general. I know that some progress has been done on this side, but that's definitely non-rigify territory. I guess you will have to disable/enable the armature modifier while sculpting.

A thing I wish for improvements on this addon: When you update the Rig from your Metarig, please let the Constraints and Drivers of the stay intact or please implement an option to do so.. it's quite a task to type them in.

we have plans for post-generation actions, the hard part is to get which ones are the constraints that the user is willing to keep. What we are probably going to implement is the possibilty to append a post-script

Since this report is about blender settings/workflow rather than rigify related I am closing the task. Please feel free to reopen in case you think there are still unaddressed issues concerning rigify

Thanks,
Paolo