Page MenuHome

Microlag on tablet pc.
Closed, InvalidPublic

Description

System Information
Operating system and graphics card
Surface pro 1 gen, win8.1, intel hd4000
Cube Mix Plus, win10, intel hd 615
PC win 7, gtx 1070
Blender Version
Broken: ( 2.79 5bd8ac9) and some older 2.72
Worked: (optional) none

Short description of error
Im having some issue with tablet pc. Few days ago ive updated surface pro 1gen windows 8.1 to windows 10 and noticed some problem with microlag when used with pen on the screen (when i try to rotate screen, or use it for painting texture. There is like 0.5s delay before blender starts to register my actions). So i moved back windows 10 to windows 8.1 and im still having same issue. Ive never noticed that before so i tried on some old version of blender like 2.72. And still same problem. Next ive pluged wacom intuos pro and with external tablet pluged to tablet pc, there is no problem (same with regular pc, no problem). So the issue exist on tablet pc. Both Surface pro 1 gen and Cube mix plus has this delay. Ive tested this in Krita and there is no problem there.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps
Regular actions, camera movement, rotate or painting texture, sculpting. Everything has this like 0.5s delay before anything starts. I can record a movie if needed.
Anyone with tablet pc/cintiqs, surface pro, wacom companins etc, can confirm this?

Details

Type
Bug

Event Timeline

Paul (rice) updated the task description. (Show Details)

Ok so i messed with the drivers and installed the oldest one that i had in my download folder and found out that all newer ones are having this lag issue. So the only one that is working is ISD_DualTouch_712-9, and ISD_DualTouch_731-7/ISD_DualTouch_7.3.4-47 are broken. I will write to wacom so they can investigate whats going on.

I finally found whats going on. So Microsoft reinvented stylus for tablet pc. From their perspective, pen should act as 11 finger. So now it works as finger, not as mouse. If i do not want lag when rotating/moving 3d view, paint, sculpt etc. i need to tap twice screen with pen before making stroke :D Microsoft you garbage piece of shit. Meanwhile i found that there is more problems with expanding or spliting windows in blender. All of this actions require doubletap. I wonder what they did in krita since all works fine there. Any ideas how to adapt those "new" changes to blender to work as previous or we wait for microsoft so they change their mind?

more info
https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/14277341/
https://answers.microsoft.com/en-us/windows/forum/windows_10-touch/pen-issues-after-the-fall-creator-update/089a9aed-bbed-4a47-9d4c-6bbad0075f9d?tm=1512345123939&auth=1

Philipp Oeser (lichtwerk) closed this task as Invalid.
Philipp Oeser (lichtwerk) claimed this task.

I dare to close this as you mentioned this is a Windows related problem regarding the Fall Creators update and I think considering the limited resources it is out of scope finding a workaround for this in blender.
Hopefully Microsoft will provide a solution rather than later.
If someone thinks its an easy fix though: feel free to reopen :)