Page MenuHome

VSE Rotation is Backwards
Closed, ResolvedPublic

Description

System Information
Arch Linux, Intel

Blender Version
2.79

VSE video rotation using transform effect is backwards.

Exact steps for others to reproduce the error

  1. Add a transform effect to a video clip
  2. Rotate that video clip using the rotation property

Rotation in the 3d view behaves as expected (clockwise). Here we are rotating a cube 15 degrees:

Rotating a video clip by 15 degrees will rotate counter clockwise

Details

Type
To Do

Event Timeline

An issue with fixing this is it will break animated rotation. Maybe worth keeping this as a breaking change for 2.8x.

Philipp Oeser (lichtwerk) triaged this task as Normal priority.
Philipp Oeser (lichtwerk) changed Type from Bug to To Do.

will try to do this (for future inclusion in 2.8 maybe)

Unfortunately I'll only be able to look at this in April again, so let others take over....

Note the compositor nodes rotation also works this way.

I took another look at this and realized I was confused. I noticed that in the 3d view, if I enter in a positive value for rotation, Blender will convert this value to a negative number (see the GIF). While I still think this is strange, there is no inconsistency with the video sequencer.

3D view isn't related since you will get different results depending on the view direction.

Daniel Oakey (doakey3) closed this task as Resolved.Jan 2 2019, 9:34 PM