AO checkbox in Combined baking affects nothing.
Closed, ArchivedPublic

Description

Hi,

With combined baking mode AO is always baked whether AO checkbox selected or not.

Blender 2.79.
System info:

System:    Host: kds-R540-R580-R780-SA41-E452-E852 Kernel: 4.8.0-58-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: SAMSUNG model: R540/R580/R780/SA41/E452/E852 v: 03KP
           Bios: American Megatrends v: 03KP.M008.20100927.LDG date: 09/27/2010
CPU:       Dual core Intel Core i3 M 370 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9575
           clock speeds: max: 2399 MHz 1: 1333 MHz 2: 1199 MHz 3: 1866 MHz
           4: 1066 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV710/M92 [Mobility Radeon HD 4530/4570/545v]
           bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Gallium 0.4 on AMD RV710 (DRM 2.46.0, LLVM 3.8.0)
           GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card-1 Intel 5 Series/3400 Series High Definition Audio
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Advanced Micro Devices [AMD/ATI] RV710/730 HDMI Audio [Radeon HD 4000 series]
           driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.8.0-58-generic
Network:   Card-1: Broadcom BCM4313 802.11bgn Wireless Network Adapter
           driver: wl bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Marvell 88E8040 PCI-E Fast Ethernet Controller
           driver: sky2 v: 1.30 port: b000 bus-ID: 06:00.0
           IF: enp6s0 state: down mac: <filter>
Drives:    HDD Total Size: 320.1GB (92.1% used)
           ID-1: /dev/sda model: TOSHIBA_MK3265GS size: 320.1GB
Partition: ID-1: / size: 291G used: 272G (99%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 3.13GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 56.0C mobo: 56.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 230 Uptime: 37 min Memory: 1667.6/2921.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

Details

Type
Bug
Brecht Van Lommel (brecht) triaged this task as Incomplete priority.Jan 11 2018, 8:28 AM

Without a .blend file attached we can't tell what exactly the issue is you are seeing, but this is probably not a bug.

When disabling Diffuse, Glossy, AO, .. for Combined baking, they no longer directly contribute to the baked results, but they do still contribute indirectly. So an object illuminated with AO will still be visible that way in a glossy reflection for example (which I think is what would be expected), and similarly for indirect diffuse (maybe a little less expected but consistent).

Philipp Oeser (lichtwerk) closed this task as Archived.Jan 18 2018, 6:39 PM
Philipp Oeser (lichtwerk) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.