Page MenuHome

Draw other objects in uv/Image editor does not work - (due to different textures or cycles)
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
Operating system and graphics card
windows 7
NVIDIA GeForce GTX 660

Blender Version
Broken: 2.79, hash 001789d, 2018-01-18
Worked: (optional)

Short description of error
Not sure if this is a bug, since it has never worked properly for me. Here comes a description anyway:

Whenever the option "Draw other objects" in uv/Image editor is on I expect to see all selected objects uv's in the uv/Image editor. Whenever the different objects has different textures "assigned in the uv/Image editor", the uv's of the different objects will not be displayed at the same time in the uv editor. Whenever I switch from blender internal to cycles, this happens as well.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

The tooltip say "Draw other selected objects that share the same image.", so this is by design. The idea is that the case where you are interested in packing UVs from multiple objects in the same space is when they share the same image, otherwise it's not a problem if the UVs overlap.

It may be useful to support other behavior here as well, but that would be a feature request.