Hair, Particle Edit automatically mirrors guide strands
Closed, ArchivedPublic

Description

System Information
Windows 7 64, nvidia K4200

Blender Version
Broken:2.79 5bd8ac9
Worked:

Description
If guide strands have been mirrored at some point and then I go on to create an asymmetrical style these automatically get mirrored when entering back to particle edit mode if x mirror is on in mesh edit mode

Exact steps for others to reproduce the error
Open file. You'll see and asymmetrical style in front view. Select object and go into Particle edit mode. Strands snap into a mirrored positions and style is lost.
It seems when x mirror is switched off in object edit mode this does not happen.

Details

Type
To Do

I can confirm that enabling/disabling X-mirror in Edit mode enables/disables it for Particle Edit mode, too.
Particle Edit mode re-uses Edit mode tools to manipulate particles.

I don't know if option can easily be set per mode. It could be considered as a known limitation.
After surprise, user can easily fix this. X-mirror option checkbox is also available in Particle Edit mode.

Philipp Oeser (lichtwerk) closed this task as Archived.Apr 27 2018, 2:35 PM
Philipp Oeser (lichtwerk) claimed this task.

Though this might be inconvenient, this seems to be by design (and not a bug) then.

These options could be duplicated for particle edit mode, but this seems more like a TODO (added here).
Also seeing a new hair system already being Work In Progress, will archive this then.

Philipp Oeser (lichtwerk) changed Type from Bug to To Do.Apr 27 2018, 2:35 PM