Page MenuHome

Blender crash after enabling GPU render on Mac. Need to restart computer before Blender can be used again
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
iMac 27 inch, mid 2011
OS: Sierra 10.13.2
Processor: Intel Core i7
Processor speed: 3,4 GHz
GPU: AMD Radeon HD 6970M

Blender Version
Version: 2.79

Short description of error

Enabling GPU compute in the render-options completely freezes Blender.

And yes... GPU options were set in system settings to OpenGL
Killing Blender and restart does not work, process keeps running in the background. Need to restart the Mac (very rare) in order to be able to run Blender again. (Otherwise Blender simply does not respond (show at all) when trying to restart it)

Separately killing the rogue process is not possible since the MAC activity-window (task manager) simply does not show (won't respond)

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

  • Start with Basic Blender start scene,
  • Switch to Cycles
  • Enable GPU-compute
  • Blender freezes

Details

Type
Bug

Event Timeline

Does --debug-gpu option give anything to the console before freeze?

No, not really,
but here's a screenshot, so you can look for yourself, perhaps spot something I've missed...

The process CVM compiler take 100% CPU , and needs to be shut down hard.

that and killing the Blender process make it possible to restart Blender

I would like to see the terminal console, it seems to hang when trying to build OpenCL kernels.

Here's the terminal output:

Last login: Tue Jan 30 11:43:13 on console
-bash: Shell: command not found
/Applications/BLENDER\ 3-D/blender.app/Contents/MacOS/blender ; exit;
-bash: /Library/Frameworks/Python.framework/Versions/3.6/bin/virtualenvwrapper.sh: No such file or directory
iMac-van-Michael-2:~ webspeaking$ /Applications/BLENDER\ 3-D/blender.app/Contents/MacOS/blender ; exit;
Read prefs: /Users/webspeaking/Library/Application Support/Blender/2.79/config/userpref.blend
found bundled python: /Applications/BLENDER 3-D/blender.app/Contents/Resources/2.79/python
addon not found: 'import_runtime_mhx2'
ENTERING RIGIFY LEGACY

Loading MakeWalk
addon not found: 'nwn2_mdb'
B4W Warning: Blender 2.78 is recommended for the Blend4Web addon. Current version is 2.79
B4W Warning: Using low version of Blend4Web binary module. Blend4Web update is recommended!
addon not found: 'io_three'
addon not found: 'add_mesh_ant_landscape'
measureit: Imported multifiles
serving at port 6687
Device init success
Compiling OpenCL program megakernel

If you start with --factory-startup, does the kernel compiling hang?

Nope,

Which means,
When switching to factory settings, enabling Cycles and then switch to GPU and start a render, it actually works!

So probably an issue with one of the add-ons then...

stupid of me not to consider this myself.... (but then again, rebooting takes really long when Blender crashes like this...)

sorry...

Let me disable a few, and I'll report back to you

Console gives this output though, (see attachement)

not finished with enabling/disabling the add-ons (monk's work)

I'll continue in the morning.

The ancient Blend4Web version add-on however wasn't the culprit....

Ah, it is not an add on problem,

going back to the factory settings disabled the GPU as the computing device,
hence it looked as though it worked, but it did not,

Thus:

  1. Going back to factory settings
  2. Enabling the GPU in the system tab as the Cycles computing device
  3. Hit the render button,

still crashes the machine :-(

It can be also your startup .blend

... can you give me an idea what to try then? I'm not a coding guru. (Unless chaos is worshipped, I that case I may stand a fair chance)

Start with --factory-startup, then do some settings you usually have, and save it as new startup.blend

And still try to find if there is some addon that messes with kernel compiling.

Arto Kitula (akitula) closed this task as Resolved.Jan 31 2018, 1:17 PM
Arto Kitula (akitula) claimed this task.

As it seems that it's not blender bug, marking this as resolved. Feel free to comment, I'll try to help.

Hi Arto,

perhaps I didn't express myself clear enough,
even with clean start-up (factory settings) the bug still persists.

I thought for a second it was fixed, but the Factory-setting also removes the system setting where the GPU is selected.

So it seems as if the GPU (in the Render-panel) is selected but it's slightly greyed out (I didn't notice that) so it doesn't do anything.

So it's definitely a Blender bug ... because my system still crashes with factory settings en GPU enabled in system panel and render panel.

Sorry for the created confusion

Arto Kitula (akitula) reopened this task as Open.Jan 31 2018, 2:08 PM

So I'll open this again, yet I can't repro.
Factory startup is just that, it removes all settings to default, and removes GPU compute selection from settings.
Check if this happens with 2.79a-rc:
Blender 2.79a rc macOS

Again, start with --factory-startup and then go to user settings and select your compute device.

Brecht Van Lommel (brecht) triaged this task as Normal priority.Jan 31 2018, 9:21 PM

From the description, this must be a bug in the Apple OpenCL driver. We've seen this before where if it's given a complex OpenCL kernel, it can hang for a longe time and eventually crash or return an error.

The question is then if we can find a way to work around it. I'm not sure any developer has this GPU available for testing though, so it's not so likely this will be fixed soon.

Even when it does work, it's very unlikely that performance will be good. On Windows and Linux we no longer support GPU rendering with this card, and probably should do the same on macOS. The hardware isn't really suited to run complex kernels like Cycles, and we don't have the time to optimize for it.

After looking through now with proper time, seems indeed some High Sierra issue.

Ok,

no GPU rendering for me then,

bummer,

ok guys,
thanks for your time!

Cheers,

Same problem here as well

I had the same issue and fixed it by unchecking the integrated graphics in user preferences

Alvaro (zevarito_b) added a comment.EditedNov 12 2018, 2:27 PM

@Isaiah McCurdy (Helium234) cannot find that option on my 2.79b installation, could you show me where you change it? Thanks!

@Isaiah McCurdy (Helium234) cannot find that option on my 2.79b installation, could you show me where you change it? Thanks!

it should be under user preferences >system (sorry for the late reply)

Hello,

I'm having a similar problem while sculpting and it suddenly hangs (with Pinwheel) I force quit but after that it causes my mac
to become unresponsive in a way I have never seen before. The mouse moves, the audio continues but I cant click on any windows.

Is this caused from force quitting blender?

Hello,

I'm having a similar problem while sculpting and it suddenly hangs (with Pinwheel) I force quit but after that it causes my mac
to become unresponsive in a way I have never seen before. The mouse moves, the audio continues but I cant click on any windows.

Is this caused from force quitting blender?

Probably, I would reinstall blender and see if that would work

Same problem here, in both 2.79 and 2.8

Brecht Van Lommel (brecht) closed this task as Archived.Dec 8 2018, 2:18 AM

Cycles: OpenCL on macOS has been disabled

There was a growing payload of bugs in Cycles related on OpenCL on macOS
platform, and those issues were caused by a compiler bug, which we have no
control over.

Surely, it is sometimes possible to work compiler bugs around from a
source, but we are facing some of the issues which are not solvable in this
way. Also, such solutions are usually short-living,. since adding more
features are often kicking compiler to provide buggy binary again.

In this case compiler will not get fixed since Apple decided to discontinue
OpenCL on its platform.

So the decision was made to drop support of OpenCL, keep official features
of Blender stable and predictable, and focus on things we have control over.

P.S. Older Blender releases are always available. Surely, this sounds like
using an ancient software without neat features. But we can't push Cycles
OpenCL on macOS measurably beyond that anyway.

https://lists.blender.org/pipermail/bf-committers/2018-December/049695.html

what is the solution to this? i just downloaded 2.79b to my mac 2011 and now i get error; 'could not open file for writing'.
any suggestions to a work around in order to render work?

@shawn (noahnoah), that's unrelated to this bug report. Possibly the path you are rendering to does not exist.