Texture Panel in Brush , Brush Mask options for Properties Panel doesn't show
Closed, ResolvedPublic

Description

System Information
Linux Mint GTX 660ti, Mac OS Sierra ATI Radeon HD 5770 1024 MB

Blender Version
Broken: (example: 2.8 2018-02-07 23:41 hash 42c99ee55f51)
Worked: (optional)

Textures used as brush or brush mask interfere with application of paint to different slots, main issue is Texture Panel in Properties Panel for Brush and Brush Mask doesn't show any of the sub panels with all the settings for the procedural textures so as to set them up to use.

Exact steps for others to reproduce the error
Open the file from https://drive.google.com/file/d/1lVdkhkQphI2ZCspGhP-C3G59ZgB9pe9V/view?usp=sharing
Set the Display to full shading and then select a texture slot to paint to, using the embedded texture brush mask, and look for the panels to adjust the brush mask texture in the Properties editor. You won't find them, and even if you adopt another texture type from the drop down, you won't see anything to adjust with.

Performance issues compared with default TexDraw brush to color on Color_paint_head, on Linux mint I had issues with getting color to show up, even making sure to delete and preexisting procedural textures in the brush settings. On Mac, got the paint to work but very very slow performance on this 2010 MacPro. Still no texture brush panels showing in the properties editor.

Exchange with Dalai Felinto prompted me to report it, though I understand this may be a design change or just ignorance on my part - I paint, so I look for this to work like 2.79 paint system.

Details

Type
Bug

Related Objects

Dalai Felinto (dfelinto) closed this task as Resolved.Mar 14 2018, 5:59 PM

I believe I fixed that already.

Okay, I see now. If using Eevee for painting, they do not appear. If using Cycles, they appear - but you can't use them really in Cycles, so we must wait for the Workspace engine to be built or for Eevee to support painting. Thanks for looking.

@Craig Jones (craig_jones) can you post a picture showing the panels in Cycles, and the absence of them in EEVEE? I'm not sure of which panels you are referring to.

Here is a test cube with the default generated texture and color grid and a cloud texture as a brush texture.

cycles
{F2444802}eevee

The panels on the right in the Properties Editor show when in Cycles, but when you switch to Eevee they disappear on redraw of the window.

Alright, can you share this .blend? Your original .blend is way to big and massive. This one can be shared with no texture packing and saved "compressed" from within Blender.

Here is the file saved compressed in 2.8.

For the records, the fix is P635 plus a Clay and EEVEE specific implementations for the texture panels.