Page MenuHome

Subsurf modifier is affecting the way in which the brush paints weights.
Closed, ResolvedPublic

Description

I'm using master.

I'm attaching an example file, basically the default cube. In weight painting mode I've set the strength of the brush to 1 and no falloff in the curve. If you paint a vertex with subsurf OFF, you'll see that it behaves as expected and the vertex is assigned a weight of 1.0.

The problem comes when you enable subsurf, paint one vertex and you will notice that the assigned weight is not 1.0, but it seems to be somehow divided by the level of subsurf! If you paint with a subsurf level of 1, the weight is 0.5, with a level of 2 it is 0.333 and so on.

If this is some kind of new feature, it should definitely have a toggle! :D

Details

Type
Bug

Event Timeline

Definitely looks like something weird is up. I also noticed that it seems to work with Accumulate enabled.

ronan ducluzeau (zeauro) triaged this task as Confirmed, Medium priority.

Problem only occurs into master. No change in 2.79aRC.

It is related to new improvements on vertex weight painting. But it is a bug.

Clearly, here, brush does not not behave as intended.
User defines a weight and a strength that are not respected.

Sergey Sharybin (sergey) closed this task as Resolved.
Sergey Sharybin (sergey) claimed this task.

Should be fixed by rB5e332fd700fb.
Thanks for the report, closing.

P.S. If it still happens for some reason please make an updated report.