Page MenuHome

Blender 2.79a crashes immediately on Laptop
Closed, ArchivedPublic

Description

System Information
Windows 7 x64 bits. Gateway nv53a laptop> Athlon IIP320 Machine dual-core 2.10 ghz with 4gb Ram. Ati Mobility Radeon HD4200 series for graphic card.

Blender Version
Broken: 2.79a - Can´t create any geometry except torus.
Worked: (optional)

Short description of error
Immediate crash upon creating any geometry
I try to create a primitive mesh and blender closes. Only torus is the only one that can be done trhough SHIFT+A or clicking the UI button. All other primitives crash blender. I deactivated some of the addons and the crash still continues.

Exact steps for others to reproduce the error
This blender directory is on a different drive than default blender´s directory. Blender 2.79a is unpacked on my D:\program files\Blender 2.9-a. I open blender and create a primitive mesh. Application closes immediately.

Details

Type
Bug

Related Objects

Event Timeline

LazyDodo (LazyDodo) triaged this task as Needs Information from User priority.

ts highly likely that this bug is specific to your hardware/driver configuration. These kinds of display issues are often caused by OpenGL driver bugs.

While its possible a software error in Blender, its worth checking if this functions correctly...

After upgrading graphics card drivers.
On a different system (with different hardware/drivers).
Using a Software OpenGL renderer...
On Linux/macOS, Official releases come with blender-softwaregl
On MS-Windows: Download this dll and copying it so its located in the same directory as 'blender.exe' and run Blender normally.
If this is a driver bug, or we can't link to this to an error in Blender's code, the report may be closed as a driver error, so please help us determine whether this is a bug in Blender or not.

I am experiencing same behavior.
The title of this issue should be renamed to "Crashes on Edit-mode or mesh creation"
I've been running 2.79rc2 since August for hours at a time. Still works and is very reliable.
After the blender crash, I updated my graphics driver using the Windows driver update, rebooted, blender does the same crash.
I copied the opengl32.dll (linked above) into the same directory with the blender.exe. Same crash behavior.
I set the startup to factory settings, same crash behavior.

Probably the same as T53996 .

Steps to Reproduce:

  1. start blender.
  2. click to dismiss splash screen
  3. looks normal.
  4. Tab OR click to edit-mode OR Shift-A choose mesh cube.
  5. Blender window closes really fast.

Blender -d output:

C:\Users\j\Downloads\blender-2.79a-rc-windows64>blender.exe -d
Switching to fully guarded memory allocator.
Blender 2.79 (sub 0)
Build: Tue 01/23/2018 07:00 AM Windows
argv[0] = blender.exe
argv[1] = -d
read file C:\Users\j\AppData\Roaming\Blender Foundation\Blender\2.79\config\userpref.blend
  Version 279 sub 0 date 2017-08-18 12:53 hash 7b397cd
Read prefs: C:\Users\j\AppData\Roaming\Blender Foundation\Blender\2.79\config\userpref.blend
read file C:\Users\j\AppData\Roaming\Blender Foundation\Blender\2.79\config\startup.blend
  Version 279 sub 0 date 2017-08-18 12:53 hash 7b397cd

ordered
 OBPlane
found bundled python: C:\Users\j\Downloads\blender-2.79a-rc-windows64\2.79\python
measureit: Imported multifiles
ED_undo_push: Add Torus

ordered
 OBTorus
 OBPlane
Error: Unrecognized Exception

C:\Users\j\Downloads\blender-2.79a-rc-windows64>

Display:

AMD Radeon(TM) R5 Graphics
Adapter Type	AMD Radeon Graphics Processor (0x9851), Advanced Micro Devices, Inc. compatible
Adapter RAM	1.00 GB 
Installed Drivers	aticfx64.dll,aticfx64.dll,aticfx64.dll,amdxc64.dll
Driver Version	15.201.1301.0
INF File	oem24.inf (ati2mtag_MullinsPA_Mobile section)
Resolution	1920 x 1080 x 60 hertz
Bits/Pixel	32
Driver	c:\windows\system32\drivers\atikmpag.sys (8.14.1.6463, 660.51 KB (676,360 bytes), 8/1/2015 2:28 AM)

My system

Microsoft Windows 10 Pro  10.0.16299 Build 16299
Model HP 23-q153la
System Type	x64-based PC
Processor	AMD A8-7410 APU with AMD Radeon R5 Graphics, 2200 Mhz, 4 Core(s), 4 Logical Processor(s)
Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.