Page MenuHome

The video editor doesn't work properly in 2.79
Closed, DuplicatePublic

Description

System Information
Operating system: Xubuntu 17.10
GPU: Nvidia Geforce GTX760

Blender Version
Broken: 2.79, 2.79a, 2.80
Worked: 2.78

Short description of error

Blender does not detect correctly MKV videos length.

Details

This seven and a half minutes MKV video is imported as having over 400k frames.

Hard to describe by words, so I've made the video: https://youtu.be/rJbKQp4yle4
This problem is observed both in 2.79 and in 2.79a release candidate. The problem does not depend on render engine selected.

Details

Type
Bug

Event Timeline

Christopher Anderssarian (Christopher_Anderssarian) triaged this task as Needs Information from User priority.

Thanks for your report, unfortunately this is not enough information to recreate the bug.
Please share the video in question (or another that shows the same results).

Thanks for your report, unfortunately this is not enough information to recreate the bug.
Please share the video in question (or another that shows the same results).

https://drive.google.com/open?id=1O1-xxIPdGRuOMoZ_BpveuX5N445WhO8V

Christopher Anderssarian (Christopher_Anderssarian) raised the priority of this task from Needs Information from User to Normal.Feb 24 2018, 1:39 PM

Thank you, I'll check when I get home.
This might be related to T53003

Christopher Anderssarian (Christopher_Anderssarian) raised the priority of this task from Normal to Needs Triage by Developer.Feb 25 2018, 1:12 AM

This actually looks more like T53857, can a mod or an admin confirm and/or do a merge or set as duplicate whichever is appropriate.

Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.

There’s nothing difficult to explain here, please refrain from making bugreports as videos, this is a much inefficient way (both for you and us developers).

That said, I think the issue is either in the MKV files themselves, or in current versions of FFMPEG. Here on linux, with latest ffmpeg version from Debian Testing, it reports those MKV files as being 1000 frames per seconds ones, so looks like Blender itself is handling correctly information returned by FFMPEG…

Will let @Sergey Sharybin (sergey) have final word here though.