Page MenuHome

First and second particle overlap when they shouldn't
Closed, ResolvedPublic

Description

System Information
Windows 8, Nvidia

Blender Version
Broken: 2.79 5bd8ac9

Short description of error
With Particle/Face option to 1
and number of particles equal to number of faces
Expecting - one particle per face.
Result - First face has two overlapping particles and the last face has zero particles.

Exact steps for others to reproduce the error

Create default Grid (9x9 = 81 faces)
Add particle system to it with Start and End equal to 1
By given number of particles equal to the number of faces of the grid and setting Emit From:

  • Faces
  • Particle/Face option to 1
  • Random - off
  • Even Distribution - on

Download blend:

Turning off Even Distribution - shifts particles from index 40 up, so now the empty face is in the middle, but still 0 an 1 particles overlap.

Details

Type
Bug

Event Timeline

Sergey Sharybin (sergey) closed this task as Resolved.
Sergey Sharybin (sergey) claimed this task.

Thanks for the report, but it was already fixed in rB35ee9ff.

It is quite dangerous change (since it changes distribution, which will cause different render results), so it was not ported to 2.79a. You can use latest buildbot builds though.

Thanks Sergey!
You are right about new particles messing up old projects.
Is it possible to work around it using Python?

Is it possible to work around it using Python?

Unfortunately, no. This logic is somewhere deep inside of C code, which has no bindings or handles exposed to Python.

We are using master branch here at the Blender Institute on a daily basis, so it's not too bad to use it if you need particles distribution fixed.