Impossible to Unlink Material Animation Data?
Closed, InvalidPublic

Description

System Information
Windows 8.1 Home 64 bit
Nvidia Geforce GTX 970
Intel Core i7-5930K CPU @ 3.5 GHz
32 GB RAM

Blender Version
Broken: (2.79, d640ce4)
Worked: (unknown)

Short description of error

Hi Blender team, I've encountered a weird bug of which I'm not sure if this has already been fixed in one of the nightly builds. When you animate a material node in Cycles, then duplicate the object and make a new single user material, somehow the animation data is still linked, meaning if you delete your keyframes on the 2nd material, the 1st material's keys will also be deleted. You can successfully unlink any other type of animation data (such as translation/rotation) by deleting the duplicated Action for the new object. Unfortunately, material animation data is not linked to Actions... so you can never truly make a single user material that originally had keyframes in it.

Steps to reproduce

In a new project, add a simple emission shader to the default cube. Animate the strength property. Duplicate the cube and create a new single user material. Now right click the strength property in the new material and Clear Keyframes. The keys will also be cleared in the original material.

Also, if you first add a new, separate emission shader to the 2nd material and plug it into the material output, THEN delete the old unconnected emission shader that has the keyframes, your keyframes in the original material will also be lost.

Thank you for your time in looking into this.

-Adam

Details

Type
Bug

Ugh... the same thing is true for Curve path animation data (evaluation time). Duplicating a portion of a curve that has an animated eval time so you can modify the trajectory at a specific point without affecting the original path is currently impossible due to both paths incorrectly sharing the same data block. Does anyone know of a workaround for either issue? Surely materials and curves cannot always be animated as a final step after all duplication is done, otherwise that would hinder the creative workflow tremendously.

Thanks.

-Adam

Adam Janz (Copperplate) closed this task as Invalid.Feb 27 2018, 5:39 PM
Adam Janz (Copperplate) claimed this task.

Praise God for showing me the solution! In the outliner, type "Animation", then right click on the object's animation data you want to remove and click "Clear Animation Data"; or just hit Spacebar and type "Clear Animation". It's too bad there's no interactive context for clearing this as we have with Actions, however, it's great that a simple solution is available. :-)

Thanks.

-Adam