Bevel operator percent mode doesn't work properly
Closed, ResolvedPublic

Description

System Information
Windows 64bits & MacOS

Blender Version
Broken: 2.79.3 actual master
Worked: 2.79a

Bevel operator percent mode doesn't work properly like we can see in this image (see the weird curve in the bevel solution)

This is the correct behaviour

And strange behaviours happens in other situations, for example, in this model (box without caps and with top side scaled). In this case make same that offset edges.

Exact steps for others to reproduce the error
Create similar situations to example images and make a bevel, it allways happens in my builds (master and soc-2107-normal-tools) in windows and macOS

Details

Type
Bug
Alberto Velázquez (dcvertice) renamed this task from Bevel to Bevel operator percent mode doesn't work properly.Mar 4 2018, 10:51 PM
Philipp Oeser (lichtwerk) triaged this task as Confirmed priority.

I can confirm only with loop_slide option enabled (seems like without that option behaviour didnt change?)

This started changing in rB561d738eaa2f64044, it's possible this is intended behaviour (or a tradeof?)

@Howard Trickey (howardt) : mind having a look?


(for convenience, even tough it's very simple)

Thanks for the report. I can confirm too, and will fix. This was an unintended change when I made the last fix to Bevel. As Philipp said, a workaround until fixed is to turn off loop slide.

@Howard Trickey (howardt) : should we close this then (since you commited rBcd3f5983cd21)?

Howard Trickey (howardt) closed this task as Resolved.May 7 2018, 1:22 PM

Yes, this is now resolved. Closing.