Page MenuHome

Animation not following F-curve sometimes correctly with stepped modifier
Closed, ArchivedPublic

Description

System Information
Windows 10

Blender Version
2.79a

Short description of error
I was not able to figure out the exact steps to reproduce this, but I have a file that loads the error every time I play it.

So I have an empty that is having an animation for its rotation, (empty located to 0,0,0) and then I have a camera which is parented to the empty and the camera has an animation to make it move to the z-axis. I added for both of those animations the cycles modifier and after that the stepped modifier. Now it seems that the rotation is happening 1 frame later than the movement even tho I have exactly same F-curve for both animations. So the rotation animation is not following the F-curve in my file. Image of my setup: https://i.imgur.com/b9Tnnr1.png

I "fixed" the problem by adding 1 frame offset for the stepped modifier. Later when I played with the keyframes, the problem disappeared and I could not reproduce it, so this blend file is only proof that such error even happens sometimes. Blend file: https://www.dropbox.com/s/jhs4za2tlfrpg9l/tetris%20-%20Copy.blend?dl=0

Details

Type
Bug

Event Timeline

Joshua Leung (aligorith) closed this task as Archived.
Joshua Leung (aligorith) claimed this task.

It turns out that the step sizes for the two step modifiers were subtly different (i.e. probably in one of the really small decimal places). The difference is one of those that's too small to show up in the number buttons, but simply clicking in and out of the textboxes should make the difference go away.

I'm not sure exactly how that crept in. I'm guessing it may have happened if/when you dragged the number slider to select the value, instead of typing it in directly, some numeric/float precision issues would have caused this discreptancy.

So, since this isn't really something that the modifiers are doing wrong, I think we can close this.