Page MenuHome

Blender Cycles Render make weird scratches on surface of objects when it's following path
Closed, DuplicatePublic

Description

System Information
My laptop:
GeForce GTX 1060 6gb with Max-Q Design
16 GB RAM
i7-7700HQ CPU @ 2.80GHz
Windows 10 (x64)

and also other PC with similar set up, the differences:
32 GB Ram,
GeForce GTX 1070 TI

Blender Version
2.79a Hash: 8928d99270f, Date: 2018-02-21 (but in just 2.79 was the same problem)

Short description of error
When pieces of a car parrented to an Empty Cube (called: "CAR") are moving (because of the Empty Cube movement by Follow Path Constrain), after frame 328 it is starting to makes weird scratches on the surface of the objects. Regardless of Motion Blur, Material Settings, World Settings, Modifiers... But when you disable the Follow Path Constrain on the Empty Cube the scratches are gone.

The very extreme sctraches are visable after frame 420.

Exact steps for others to reproduce the error
Just turn on rendering, even in viewport

Details

Type
Bug

Event Timeline

I can reproduce this.

I have simplified the scene.


Go into rendered preview. There is a black stripe on the bottom left corner of the object.
The stripe seems to get thicker the further the object is away from the origin. However the numbers seem to small for it to be a floating point inaccuracy.
The effect also gets stronger, when the Bounces Max is decreased.

Brecht Van Lommel (brecht) claimed this task.

Thanks for the report, this appears to be another variation of a known issue that we are trying to address in D1212 for example. Small features far away from the original are problematic for raytracing.